Roon ARC and ROCK Port Forwarding

Roon Core Machine

Roon ROCK on a NUC

Networking Gear & Setup Details

TIM (Telecom Italia) Hub Modem Router - used as modem only
TP Link Archer A6 Router for both wifi and ethernet
No VPN

  1. Who is your internet service provider?

TIM - Telecom Italia

  1. Please list the make and model of your modem and router?

TIM Hub router/modem - model unknown
TP Link Archer A6 router

  1. Do you have any additional network hardware, like additional routers or managed switches?

TP Link Archer A6 router

  1. Does your network have any VPNs, proxy servers, or enterprise-grade security?

No

Connected Audio Devices

QUAD Vena 2 Play amplifier
Chromecast audio
JBL speaker with Chromecast audio

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

Error message as follows.-
{
“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“87.ddd.eee.fff”,“actual_external_ipv6”:“null”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.0.1”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/\” s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">718ConflictInMappingEntry</s:Fault></s:Body></s:Envelope>”}
}

Further comments:-

I’ve just switched to a NUC running Roon ROCK from a Windows 10 laptop.

I also had problems using the laptop and eventually used this with DMZ through the modem - the router does not appear to be causing a problem.

But having switched to the NUC, this no longer works, and the error message I have is different.

Roon works ok with the control app, but ARC will not connect at all.

Erm, please don’t go down the DMZ route again…

Hi geoff - Yes, I’ve switched that off, thanks. But I couldn’t find any other way to make ARC work for me on the windows laptop… :frowning_face:

You would probably need to login and do it manually on your TIM router, as via upnp it doesn’t seem to work.

(example for another router here)

Hi @Andy_Critchlow ,
Thanks for your patience while we worked through the queue. The symptoms you’ve described usually mean that Roon has autoassigned a port that is being used by other software. You can solve this by going to Roon → Settings → ARC and try changing the port until it works. 56000 is a good starting point. If that doesn’t work increment the port number by one thousand. If you’ve already set a manual port forwarding rule you will need to change that port number to match the new one that Roon is using.

Hi Daniel - thanks for this, I’ll try it and see how I get on. I suspect I’ve got a double NAT conflict going on as well though.

Hi Daniel - I resolved this issue, thank you. In fact it seems my router was connected to my modem router by DHCP rather than PPOE, and once I changed this, ARC worked immediately.

Thanks for your help.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.