Roon ARC and TP Link M4-CG-NAT Issue, Tailscale Setup Request

Just got a new router now I am hoping to make Roon arc work but not having luck. The guides don’t seem to help much. Anyone have this model router?

@Abrahams_Bogere, I moved your post to the Port Forwarding support category so the community and Roon staff may better support you.

We need a bit more information to be able to assess what you are seeing. Can you please fill out the following information:

Describe Your Setup

It’s important that you include all relevant setup information so our team can get a clear understanding of the issue.

Your post should include:

  • Details on your Core machine (OS, Hardware specs, Roon build)
  • Details on your Remote(s) (OS, Hardware specs, Roon build)
  • Networking details (especially what hardware you’re using, how everything is connected, and anything notable about how it’s all configured)
  • Audio devices in use
  • Library details (where your music is stored, whether you’re using a streaming service, how many tracks are in your library)

Including these details in your post helps us resolve your issues faster.

Additionally, regarding ARC, what error message are you seeing in Settings → Roon ARC, and can you please add the following details:

  1. Who is your internet service provider?
  2. Please list the make and model of your modem and router?
  3. Do you have any additional network hardware, like additional routers or managed switches?
  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?
  5. How is your Roon Core connected to the internet?

I have a 2014 Mac Mini Monterey as my core. Internet is T-Mobile Home internet but I just installed a new router TP Link Deco M4 mesh setup.

There is an option to port forward but I’m not exactly sure on the settings and steps needed to be done. It isn’t as straightforward or automatic as advertised.

@Abrahams_Bogere, does the Deco connect to the ISP supplied router/ modem?

Also, please navigate to Roon Settings > Roon ARC, and share the text between the braces: {…}. Thanks.

This is what is in between the braces.

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:“”},
“status”: “status”: MultipleNatFound
“natpmp_autoconfig”: {“server_ip”:“”,“found_natpmp”:true},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true}

1 Like

@Abrahams_Bogere, the port forwarding diagnostics you’ve provided suggest there is a redundant layer of network address translation preventing port forwarding.

This can either be at the local-network level (commonly as a result of two routers), or at the level of your service provider (in the form of carrier-grade NAT).

If your setup involves an ISP-provided gateway (modem/router combination) and your own third-party router:

  • In the web administration interface of the ISP-provided gateway (modem/router combination), enable Bridge Mode or equivalent, where the ISP-provided gateway does not have DHCP routing enabled.

  • Alternatively, if you have already created a manual port forwarding rule in your 3rd party router, you can add an additional rule to forward the port through the ISP/second router.

If you only have one router in your setup or your modem is already in Bridge mode, please take a look through our list of known router and internet service provider solutions, as other users may have already encountered the same situation: ISPs and Routers: List of Known Solutions and Workarounds

You can reach out directly to your service provider to ask if they support port forwarding; this question will often enough to prompt them to explain whether or not the carrier-grade NAT they’ve implemented can function with ARC.

More specifically, you can pass along the following questions:

  • Have you implemented carrier-grade NAT for my account level?
  • Have you fully implemented IPv6, or do you have IPv4 addresses available?
  • Can I request a static IPv4 address to support port forwarding?
  • Are there any ports you have reserved at the ISP level I should be aware of?

If you’re unable to locate an existing solution in our #support:port-forwarding-resources subcategory, please reach out to the Roon support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?
1 Like

Yeah my ISP is T-Mobile Home internet. I thought getting my own router would solve this but it looks like it doesn’t.

Any chance you will get an update to help this?

It looks like you have a public IP, so this is good news. So, the likely issue is having two routers in your network.

Internet → [ T-Mobile router 192.168.12.???] → [ TP-Link router] → [Roon core 192.168.68.???]

To assist, please provide the following information:

  • Make and model of the T-Mobile supplied router (should be printed on the rear or base)
  • The IP address of the T-Mobile supplied router, so you can connect to the admin interface
  • The IP address of your Roon core (this is shown under Settings > Roon ARC)
  • The Roon ARC port (also in Settings > Roon ARC)

The next step is to either set up port forwarding in the T-Mobile supplied router or switch this to modem or pass-through mode (you don’t need to worry about these terms.) You also need to make sure Wi-Fi is disabled on this device and no devices, apart from the TP-Link router, are connected to it via Ethernet.

Once this is done, the TP-Link needs setting up for UPnP or port forwarding.

HI @Abrahams_Bogere

I use a TP-Link Deco X68 mesh system, I think the app used to manage them is the same, I had to set up a manual port forwarding rule to get ARC to work with the Telstra NBN connection but now it works flawlessly.

If you go into the TP-Link app select More=>Advanced scroll down to Port Forwarding, then it is very easy to set up a Port Forwarding rule:

If that doesn’t help then I think it is a CG-NAT issue and you might need to call T-Mobile and ask if you can either opt out of CG-NAT or pay extra for a Static IP.

1 Like

Have just been doing some reading on the T-Mobile forums and it looks like this is most definitely due to T-Mobiles implementation of CG-NAT, apparently they do not offer Static/Public IP’s unless you are a business user.

Users of Starlink have a similar issue: Starlink (ISP) with ARC: CG-NAT Requires VPN Workaround (See Staff Post) - #18 by ipeverywhere

Mark, yes, just getting back to this. T-Mobile Home Internet has some network configurations that are not modifiable and restrict the ability to run ARC. I believe Roon has reocmmended a VPN service such as Tailscale as a temporary solution until Roon can review other options that may be solutions in future versions of ARC.

1 Like

How do you implement tailscale? I think that app has been causing my core to manually restart.

Is Roon looking at updating arc to work with CG-NAT. I really thought getting a router would help with this.

I am a fellow user and cannot speak to what Roon’s development plans are. They have recommended it for CG-NAT networks, here is an example thread discussing it:

I am not a cusotmer of Tailscale so cannot comment on how to set up the service, but others may see this post and provide some assistance. Would you like me to edit your title to request Tailscale assistance?

Yes actually. But more specific for macs. That would be good.

Just updated the title Abe, hope the broader community can assist you with the Tailscale option.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.