Roon ARC, AT&T, Nokia BGW320-505, Orbi RBRE 960

Roon Core Machine

Intel NUC 11 Pro NUC11TNHi7 Barebone System - Ultra Compact - 1 x Processor Support Core i7 11th Gen i7-1165G7 Quad-core (4 Core), 8 GB Ram, OS 1.0, Roon Server Software 2.0

Networking Gear & Setup Details

ISP is AT&T Fiber. Router is a Nokia BGW320-505. The NUC is plugged into the main ORBI Router, we have a whole home mesh system.

Connected Audio Devices

Currently only streaming to various PCs and a Sonos Play:5 system.

Number of Tracks in Library


Description of Issue

I am having difficulty setting up ARC with my internet setup. We have ATT, and the main router feeds an ORBI system. If I plug the NUC directly into the BGW320-505, I am able to get ARC to work. But, since all of the devices I want Roon to stream to are connected to the Orbi system, they no longer show up as available devices. I have gone through in detail this post:
(Arc port-forwarding solution: ATT BGW320 and Asus AX-88U) and have followed the instructions as close as I can(even though I’m using the ORBI and not the Asus). Port Forwarding looks good, but I’m still not having any luck. Is it safe to post my error message from the Roon ARC screen? I’ve seen some people comment that there were certain lines where someone could steal your IP, I guess I’m showing my cards as to how technically inept I am, and it’s no wonder I’m stuck!

Thank you for your help.

@Sean_O_Donnell, welcome to the Community. I have a similar configuration, but a different gateway and different router on AT&T Fiber.

There are two options:

  1. Set the Orbi to bridge mode and let the BGW320 handle all routing and IP address assignment

  2. Have all network connections run through the Orbi, with the Orbi being the only device connected to the BGW320, and de-activate WiFi on the BGW320. The Orbi and BGW320 both remain in router mode (this is similar to what I have).

Then for Option 2, do the following:

A) Create a port forwarding rule on the BGW320 from the BGW320 to the Orbi using the LAN IP address of the primary Orbi router and the port number being what is shown in Roon’s Settings → Roon ARC tab.

B) Create a port forwarding rule on the Orbi router from the Orbi router to the computer running your Roon Core using the LAN IP address of the computer running Roon Core and the port number being what is shown in Roon’s Settings → Roon ARC tab.

Robert F,
If I could buy you a beer, a coffee, a shot of bourbon, by golly I would. This ROON Arc is ready and running. A million thank yous.

1 Like

FOR ANYONE READING THIS LATER, I used option 2 in what Robert mentioned above and that is what fixed my issue.

Glad to hear Sean, enjoy ARC!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.