Roon ARC - AT&T U-verse router double routers pass through instruction

This is the instruction for those who have their own router set up behind the provided router from AT&T U-verse.

For example, in this setup, I have AT&T U-Verse BGW320-505 → Asus router AX3000 → Roon Core (running on Windows 10).

In this case, RoonARC will be behind two NAT and will not be able to connect outside of your house.

You must follow the steps bellow to set up NAT passthrough in your own router and ATT router

  1. Enable UPnP in your router (my case: AX3000). Can be found under WAN - Internet Connection - Enable UPnP.
  2. Go to Port Forwarding tab and add port forwarding rule for your Roon Core. The internal port and external port in my case is 2022; and the internal IP address will be your Roon Core IP address.
  3. Go to your AT&T router, navigate to Firewall - NAT/Gaming
  4. Under NAT/Gaming page: click on Manage Custom Services button, create the new service called Roon. The device will be IP address of your router (AX3000) at the WAN side. The Ports will be TCP/UDP 2022.
  5. Save the setting and restart both routers.
  6. Go back to Roon Core - Settings - Roon ARC and enter port 2022.

Voila! You have successfully set up your Roon ARC under double routers NAT network.

Note: the port I used (2022) is just an example. You can use any port you want using the exact instruction.

ATT instruction 0

Putting the modem in bridge mode would be another option. Then you wouldn’t have to configure port forwarding on two different devices.

My device does not have a bridge-mode option, unfortunately. But, if your modem offers that option, then power to you!

I’m pretty sure it does. That web GUI looks awfully similar to mine (GBW210-700). Mine didn’t have a “bridge mode on” toggle if that is what you are looking for. I had to google it and go through a series of steps, but once I got it into bridge mode (years ago) I never had to touch it again.

Would be nice if you remember the steps.

My method is working though, but it would be nice to place the ATT router into bridge mode. The ATT technician told me it could not be done, but I know they are not competent.

AT&T does not allow bridge mode. The work around, which I have share several times today is: Enter the modem set up via IP address > Firewall > IP Passthrough > Set to “Default Server” > Choose from devise list or manually enter your 3rd party router’s IP address > Save.

1 Like