Roon ARC cannot access Roon Core

Roon Core Machine

Intel NUC running Roon Rock

Getting the following message when trying to connect Roon ARC to Roon CORE

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

Networking Gear & Setup Details

<! Nighthawk D8500 no VPN

Description of Issue

After updating to 2.0 cannot connect Roon ARC to Roon Core

Hey @Glen_Giffen,

Apologies for the delay in my response! Thank you for reaching out for assistance with port forwarding. I’ve split your post into a separate thread so the team and other users can assist you more directly.

Typically, errors like the one you see can be caused by a misconfigured Port Forwarding setting, if you are not seeing Ready listed in Roon Settings -> Roon ARC, please look over this guide before proceeding.

If you have reviewed this guide and still have not resolved the issue, can you provide the following details about your network setup to help expedite troubleshooting?

  1. Who is your internet service provider?

  2. Please list the make and model of your modem and router?

  3. Do you have any additional network hardware, like additional routers or managed switches?

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?

  5. What machine are you using as a Roon Core, and how is it connected to the internet?


This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.

Nothing has changed in my setup and I’ve been using Roon ARC with no problems since release. Now, I can’t get ARC to connect to my Roon Core. Port forwarding has been set up manually etc.

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

Hi @Glen_Giffen
Could I trouble you to share screenshots of the Arc settings page in Roon Remote and also one of the screen with the port forwarding rule. The error to me still suggests it’s not set correctly.

1 Like

Glen have you tried a restart of your Roon Core.
I have had this issue a couple of times myself and between restarting the Core and my phone (if needed), it has mostly fixed it

YEs, first thing I did was to restart the Core and the phone. Also uninstalled and reinstalled Roon ARC on my Samsung phone. Thanks for the feedback Michael

Ok good start, I have seen the moderators for other connection issues suggesting to go into ARC settings and choose Reset Roon ARC, I had to that not long after it came out of beta, but I don’t like suggesting it.

Not sure if you are on iOS or Android, but of on Android, I have also had to uninstall and reinstall a couple of time’s in the 5 months of testing and live (or clear the storage) though you lose all your download files then.

Thanks for that, gave it a try. Now can’t access Roon Core even when on my local network. Very happily listening to Roon the old fashioned way though.

Sorry Glen please explain

If you can use Roon the old fashioned way (assuming Roon Remote) but you can’t use ARC?
Or something more complicated?

What platform are you running your Core on, as that suggests something deeper than just Arc settings got lost

Hi @Glen_Giffen,

Thank you for bringing your issue to the attention of the Community.

If you’ve set a manual rule, I’d verify that the port hasn’t changed in Roon → Settings → ARC, and that it still matches the port you’ve assigned in your router web administration.

Do you have any firewalls engaged on your local network? What about other network security?

I’d also verify that a router automatic reset didn’t disable or reconfigure UPnP, if ARC had been relying on that protocol.

We’ll keep an eye out for your response!


Hi @Glen_Giffen,

Looking through recent Community history, we’re not able to verify if this issue was solved for you. Has port forwarding been successfully automatically configured with a more recent version of ARC/Roon? We’ve made a number of improvements since you first reached out.

If you want to give manual configuration another shot, we’re here to support you. Otherwise, this topic will autoclose within the next week. Thank you!

Hi @Glen_Giffen,

Recent diagnostics from ARC show cellular connectivity, but there’s also a warning trace suggesting you might still be having issues syncing with your Core.

If that remains the case, and you haven’t tried a database refresh already, please take the following steps to fully refresh your NUC’s credentials with ARC:

  • First, create a Backup if you don’t have a reliable recent backup of your database already. This will make sure you don’t lose library content, DSP settings, etc.
  • Stop RoonServer from running in ROCK’s WebUI
  • Navigate to your ROCK’s Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Restart the RoonServer in the WebUI to generate a new Roon database folder
  • On the Roon Remotes, press “Use another Core” and connect to the new database

From there, you may have to redesignate the port assignment in Roon → Settings → ARC if you’d set up a manual port forwarding rule in the Nighthawk router. We’ll be here to support and keep a lookout for your post.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.