Roon Arc Configuration trouble / Linksys Velop

Roon Core Machine

Mac Studio M1 Max running Ventura 13.3.1

Networking Gear & Setup Details

Linksys Velop MESH system

Description of Issue

Not being able to configure Roon ARC. I get the following error mesage:

“ipv6_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“201.kkk.lll.mmm”,“actual_external_ipv6”:“2804:aaa:bbb:ccc:ddd:eee:fff:ggg”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="\” s:encodingStyle="\“>\n<s:Body>\n<s:Fault>\ns:Client\nUPnPError\n\n<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">\n501\nPAL_UPNP_SOAP_E_ACTION_FAILED\n\n\n</s:Fault>\n</s:Body>\n</s:Envelope>\n”}

I’ve tried adding Single port forwarding to no success. Putting the Velop system in bridge mode has made it work in the past but that is not an option now. Any other workarounds? Thanks

I use a three node velop mesh in router mode and this is the port forward rule I made that works.

Thanks, I did the exact same thing prior to this post and it does not work.

Any other suggestions?

I’m just a fellow Roon user.

Who is your ISP?

You need you ISP router in bridge mode and the Velop Mesh to do the router duties.

I can comment further once I know who your ISP IS.

Claro, from Brazil.

My ISP router is already in bridge mode.

Any updates on this? I can use Plex Sever Remote Access without any trouble. Why is Roon ARC so difficult to set it up?

Hi @Bruno_Mello,

It appears your ISP has implemented an IPv6-format external address to your account. Doing a little digging on Google, it does appear that Claro is in the process of rolling out IPv6 to their residential-tier accounts.

While we’re testing IPv6 compatibility in Early Access, the current public version of ARC won’t function with an IPv6 external address. It should function in the near future.

However, in the meantime, you have a few options:

  1. Reach out to your ISP to inquire if a) they have an IPv6 address on your account and b) what options are available for customers who are trying to port forward. They may have a dedicated IPv4 address they can assign to you.
  2. Try TailScale or another VPN workaround (see here, for example: Tailscale implementation with ARC to circumnavigate ISP CGNAT
  3. Join Early Access by following these steps to see if IPv6 functionality will allow your network to auto-configure ARC.