Roon ARC connection problems with manual configuration

Roon Core Machine

Intel NUC with Ubuntu 22.04

Networking Gear & Setup Details

UniFi Dream Machine Pro directly attached to fibre

Connected Audio Devices

Number of Tracks in Library

Description of Issue

I’m trying to setup ARC using the manual method, I’ve enabled NAT but Roon still seems to be having a problem.

Do I HAVE to enable UPnP? From the support article, it’s described as either UPnP or manual method (NAT).
Or is my ThreatManagement maybe blocking the IP that Roon is using to check?

Hidden my actual public IP.

"connectivity": {"status":"NetworkError","status_code":504,"error":"error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined"},
"external_ip": {"actual_external_ip":"???.???.???.???","router_external_ip":null},
"natpmp_autoconfig": {"status":"NotFound"},
"upnp_autoconfig": {"status":"NotFound"}

No you do not have to enable UPnP. I have mine set to off and just set a manual rule.

Figured out my issue. I had Country restrictions enabled, I had to add United States to the allow list. Now it works.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.