Roon ARC Connectivity issue

Roon Core Machine

Intel(R) Core™ i5 CPU M 480 @ 2.67GHz 2.67 GHz
8.00 GB (7.80 GB usable)

Networking Gear & Setup Details

My Router: Nighthawk RAX45 *

  • [](javascript::wink:
  • [](javascript::wink: Firmware Version V1.0.11.112_2.0.77
    Connected via Ethernet
    Optimum Online Internet - Arris TM1602 router

Connected Audio Devices

Number of Tracks in Library

10,344 tracks

Description of Issue

Can Not connect to ARC
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“actual_external_ipv6”:“null”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

You need to either enable UPnP or NAT-PMP on the router (which one depends on the router. This should then allow Roon to configure it automatically, if everything else works). If you don’t want UPnP/NAT-PMP or if it does not work (not all routers do it correctly), you need to create a manual port forwarding rule on the router.


Ask if you have trouble doing this. If you are lucky, it works then. If not, there may be a different error in the Roon ARC settings, post the new one in this case.

UPNP is enabled on the Netgear. I will try manual port forwarding rule. Do I also need to set up a static IP

We have seen routers where it just doesn’t work with UPnP. You can also search for your Nighthawk RAX45 on the forum, there are four ARC setup threads with this model. Maybe that turns up some tips.

It depends on the router whether a manual port forwarding rule requires a static IP on the rule’s target. E.g., my Fritzbox has a local name service, so when setting up the rule I don’t select the ROCK by IP in the first place but by its network name. So if the router assigns a different IP, it does not matter. Cheaper routers may not offer a name service, but it’s possible that they still update the IP in the port forwarding rule if the router assigns a different one. And yet others may be dumb and don’t update the rule, in which case you need a static IP. (Or some routers - again my Fritzbox has that option - offer to use DHCP for IP assignment but to always assign the same IP. So, more convenient if one needs to know IPs for whatever other stuff, and same end result as static)

Port forwarding did the trick… used 55000

1 Like

Great, enjoy! :slight_smile:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.