Roon arc is not working outside my local network

Roon Core Machine

WINDOWS 10
HP

Networking Gear & Setup Details

HG8145V5 ROUTER FROM MY ISP
ARCHER C8 CONNECTED USING THE NETWORK PORT ON THE HG8145V5

Connected Audio Devices

M400 SMSL DAC DIRECTLY TO THE ROON CORE USB PORT

Number of Tracks in Library

Description of Issue

EVERYTHING WORKS FINE LOCALLY
I CANNOT MAKE ARC TO WORK
THIS IS THE MESSAGE ON ROON CORE

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“187.190.199.62”,“router_external_ip”:“192.168.100.18”},
“status”: MultipleNatFound
,
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.0.1”,“found_upnp”:true}
}

It appears that you have two routers, which means you’ll need to open ports for ARC on both routers. The correct port is shown under Settings > Roon ARC > PORT.

Dear Martin,

I only have my ISP’s Router, here I am sending you the screenshot of UPnP on it.

It is enabled and the ROON Core appears there.

There is no other Router.

The reading on the Core is this now:

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“189.203.131.207”,“router_external_ip”:“10.240.167.216”},
“status”: MultipleNatFound
,
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.100.1”,“found_upnp”:true}
}