Roon Arc No Longer Connects

Roon Core Machine

ROCK, NUC8i7BEH, Crucial 8GB Single DDR4 2400 MT/S, Transcend 128GB Nvme PCIe Gen3 X4 MTE110S M.2 SSD Solid State Drive

Networking Gear & Setup Details

Ethernet to NUC: Google WiFi, TP-Link 8 Port Gigabit Switch, Synology DS920+, Intel NUC 8

Connected Audio Devices

MacBook Pro, iPhone 12, Chord Mojo2/Poly, Chromecast Audio, Apple TV 4K

Number of Tracks in Library


Description of Issue

My old iPhone 12 mini brightness was acting strange and Apple agreed to swap it out with the exact model. I migrated everything over and replaced a few apps where the migrated apps did not work properly.

Roon Arc was one of those apps. After downloading the replacement app and connecting to Roon core, I was getting (and continue to get) this message in the Roon Arc tab:

I am able to connect to Roon Arc in my home using Wifi but unable to do so once I shut WiFi off in order to replicate outdoor use. Here is what I now see:

with the horizontal blue line scrolling on the screen from left to right, and then:

Roon Arc worked fine for me on my old iPhone. Any thoughts what might be going on?


1 Like

@David_Weinberg, in your Roon ARC app on your iPhone 12, have you gone into ARC’s settings, scroll to the bottom of the screen, and select “Reset Roon ARC”?

However, based on your error message and IP address (the, it appears your ISP is using CG-NAT, which does not allow Roon ARC to work (basically CG-NAT shares public IP addresses across many homes/locations, and ARC needs a unique/unshared public IP address to communicate with the mobile device). Roon does not have a workaround yet but is looking at various options.

To help diagnose this, can you find your public IP address and post only the first two parts of it (the, the “aaa” value is important, none of the other values)? Also, the diagnostics you’ve provided suggest that UPnP is not properly configured on your router.

Please first try the following steps:

  • Try to enable UPnP/NATPMP in the web administration interface for the router directly upstream from your Core
  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering
  • Check if your modem is in Bridge mode

If you continue to experience difficulties, please tag the support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?

I’m happy to report that I solved the problem after spending a hour or so with Google WiFi support. After rebooting my network and devices, I later realized that I previously changed my NAS password and neglected to update the new password in Roon so Roon could access my music library.

This came to light after rebooting the Roon core and then no longer having access to my library (versus the residual music data in the screenshots above). I then tried to restore. That is when I realized that the Roon core had no access to music library. After adding a network share, I was able to restore my library and then Roon Arc worked fine.

Man, what a rookie error…

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.