Roon Arc not able to connect to Roon Core (Bell Home Hub 3000, Single-Router)

Roon Core Machine

Windows 10 Pro I5 8GB Ram

Networking Gear & Setup Details

Bell Modem 3000 - Ethernet

Connected Audio Devices

Number of Tracks in Library

Description of Issue

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“xxxx”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“Did not find UPnP service with WANIPConnection on network”}

Thanks for any assitance

Some additional information. When I look at the device information in the router, it is flagged as disconnected. The IP address is static. Roon works properly otherwise.
In my home, i can connect to the Roon Arc app on an ipad.

Hi Garry,

See this post.

Hope it helps.

Kind regards,


Thanks for your helpful suggestion. I had tried this but unfortunately this doesn’t work. The same error persists.

Hi @Garry_Salisbury,

Please accept my apologies that you’ve had to wait so long for a response. Thank you for your patience and the detail you’ve provided so far about your situation.

The diagnostics you’ve provided suggest that one of two issues are to blame here. One possibility is that UPnP is not properly configured on your home network setup (likely the issue of having two routers or a mismatched setting in your modem configuration).

Please first try the following steps:

  • Try to enable UPnP/NATPMP in the web administration interface for the router directly upstream from your Core
  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering
  • Check if your modem is in Bridge mode

Another possibility is carrier-grade network address translation at the level of your service provider.

If you continue to experience difficulties, please tag the support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider?

Thanks for the response.

I have the Bell 3000 modem which I assume also acts as the router. This modem does not have an easily accessible bridge mode.

I did a short disable on the firewall and the problem persisted. I do not have a VPN.
Port forwarding is to the address that Roon indicates.

Looking at the addresses in the modem, there is a Roon IP address but it indicates it is disabled. Roon works without issue on my home network.
The roon ‘device’ is using 2.4Ghz channel.
The IP address is static and the address is set to access the internet.

Otherwise the diagnostic report still says

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“Did not find UPnP service with WANIPConnection on network”}

Thanks for any suggestions.

Hi @Garry_Salisbury,

While it’s frustrating that you’re still not up and running, there are two things working in our favor, according to your most recent report:

  1. There’s no second router in your setup, so we can rule out a second layer of NAT on your local network.
  2. Other users with the HH3000 and Bell Canada have successfully enabled port forwarding after setting a manual rule.

So, it’s likely that there’s just a misconfiguration in the Home Hub’s manual port forwarding configuration. Have you set a manual rule to point to the port listed in Roon → Settings → ARC, and would you mind sharing a screenshot at your convenience if so? Please be sure to obscure any routable external IP addresses, as the team will have to delete any screenshots that contain them for privacy.


I have set up a port forward rule. The port number is what Roon has displayed in the settings. I have placed that number in the internal port as well as both places in the external port. I have tried my desktop address as the local IP address as well as the Roon Device local IP address.

Hi @Garry_Salisbury,

  1. Does setting the Protocol to TCP in the above page change anything?
  2. Do you have UPnP enabled in the router while the above settings are in place?
  3. Do you have any firewalls on your Core device? It’s possible you’ll need to set Roon as an exception on the Windows firewall or any network firewalls you may have in place, if so.

Lastly, just to confirm for redundancy - you don’t have a second router downstream from the Bell modem in this setup? If so, that would be introducing a double layer of NAT, causing the timeout. While the Bell unit doesn’t have Bridge mode, it’s possible and quite simple to safely configure a downstream router as an “access point” to avoid this double NAT situation.

I do not have a second router.

Sorry. In answer to your questions

  1. TCP is set and I have reset it as well.
  2. Ucnp is set
  3. I will check the firewall and set an exception if needed.

I have found the problem. It was a setting I had setup up in the firewall to open a port but I neglected check one box.
Now I can give it a go

Thanks for the assistance…


Sounds good, @Garry_Salisbury, I appreciate the update. We will keep this thread open for several days in the event that you continue to experience issues.

This topic was automatically closed after 4 days. New replies are no longer allowed.