Roon Arc Not Connecting--Error 504

Roon Core Machine

iMac; 3.8 GHz Quad-Core Intel Core i5; 32 GB 2400 MHz DDR4

Roon ARC is not staying connected. Sometimes it will connect to my Roon Core for a very short time, but then it will re-test and say it cannot securely access my Roon Core.

Error message is as follows:
{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“xxxx”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.1.1”,“found_upnp”:true,“error”:“doaction request return statuscode: UnknownError”}
}

IP: Spectrum.

Modem/Router: D3.1 eMTA / Model E31U2VI

No additional hardware.

Please advise. Thank you.

Hi Kevin,

I had i similar kind of error. First i enabled Upnp on my router and ARC was up and running. Yesterday evening it broke. My solution was to disabled Upnp on my router and manually configured the port forwarding. I would suggest that you configure the port forwarding manually.

Hope it helps.

Kind regards,

Maarten.

2 Likes

Thank you very much, Maarten. Unfortunately, the instructions about port forwarding may as well be written in Sanskrit, when it comes to my level of understanding. I was hoping that one of the Roon technical support people would walk me through this, but evidently that is not going to happen.

Hi Kevin,

You know where you can find the port number ARC is using (it’s in the ARC tab under settings. If you could post a screenshot of your router where you need to fill in the port forwarding maybe i can help. Or if you have a link to the manual of the router.

Maarten.

1 Like

They will get to you but they have a lot of support requests to handle after the successful release of Roon ARC.

I found an article on wikiHow that might apply to your Spectrum router and explains how to set up a port forwarding rule. Hope this can help you.

1 Like

The post done by @Joost_Hoogland could be very helpful. I just looked at the steps and where in the steps port 80 is mentioned, you should enter the number the port number which is mentioned in the ARC tab in de Roon app.

After you followed the steps do a new test in the Roon App.

Kind regards,

Maarten.

1 Like

Thank you very much, Joost. I will definitely look into this when I have some time later today. I very much appreciate your having found this.

By the way, I hope my remark about the Roon support did not seem snarky, as I did not intend it that way. I can only imagine how many questions they must be getting at this stage of the release.

Thank you, again, Maarten. As I mentioned to Joost, I shall definitely take a close look at this a little later, and then hope that I can get everything working. I very much appreciate your help and suggestions.

UPDATE: Everything seems to be working now. Thanks very much to you both for your patience in working with someone who is not proficient with manipulating router settings and such. On Monday, I’ll see how ARC works in the car for my commute, which is mainly where I want to use it, but outside the house, it is so far, so good.

Thank you again. I will update if anything else is noteworthy.

Good to hear. Did you use the app in the wiki article?
Enjoy ARC!

1 Like

Good to hear it’s working now. As far as i know, of course you could use it in the car, but you have to use your phone to switch tracks, select an album. There is no Apple Car Play integration at this point. Hopefully this will come in a future version of Roon Arc.

Enjoy the music, both in and outside the house. Happy Sunday.

Kind regards,

Maarten.

1 Like

Yes, I did use that app, thank you.That made it much easier to understand and manage the port forwarding. It was confusing before then, because I thought there would be a way to do that on the desktop.

Once again, I am really grateful for the help!

Yes, I have been reading that there is no full integration with Apple Car Play at present, but that’s OK for now. It’s just a relief that I can get rid of my Spotify “no ads” subscription and listen to all of my music (I have a lot of obscure music that is not on the streaming services).

All the best, as well, and thanks again!

1 Like