Roon ARC not ready - Did not find UPnP service with WANIPConnection on network

Roon Core Machine

headless Mac mini (Late 2012), 2.3 GHz Quad-Core Intel Core i7, 8 GB RAM, macOS Catalina, customized with outboard linear power supply and circuit board to quiet electronic fan noise

Networking Gear & Setup Details

Centurylink C300Z (ZyXEL) modem
Core is connected by WiFi
Not using VPN

Connected Audio Devices

USB output to Aavik U-300 integrated amplifier (with DAC), driving Raidho D1 speakers.

Number of Tracks in Library

22,235 tracks on USB-connected SSD

Description of Issue

After upgrading my Mac Mini to Catalina, I found Roon updated to 2.0. (Oddly enough, USB no longer shows up as an output option; I have to use System Output and configure Sound in the core’s settings to go to xCORE USB Audio 2.0 Output).
Going to Roon ARC, I get Not ready. It shows Roon Core IP as and Port as 49454.

At one point, the error message was the one in the title, but at this point, the diagnostics data read

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},

“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:null},

“natpmp_autoconfig”: {“status”:“NotFound”},

“upnp_autoconfig”: {“status”:“NotFound”}


I have attempted most of the fixes listed. Specifically:
Turned UPnP off and then back on.

Added port forwarding:
Port Forwarding List
LAN IP Protocol Ports Forwarded Remote Defined TCP 5500 No

Disabled firewall for IPv4 on router temporarily and disabled firewall on core machine.

Verified that firmware on the modem was up to date.

I tried from a laptop on the network running a port scan on port 5500 and it shows the port as closed (don’t know if that’s expected or a problem).

Thank you for your support. I am very excited about this feature; I am going to drive across the country in three weeks and would love to have Roon go with me!

Port number should be 55000 which is the Roon default, or any that you choose above 10000.

Thank you. I corrected the port number to 55000. I had previously tried ARC connecting locally, which worked. However, when I choose a composer while connected to a different network than my Core, I get the scrolling searching indicator, and then a message, “Can’t connect to your Roon Core–Check your Roon Core and try again.” On the core, I looked at the listening port, and saw it is 49454, so I added that port to my Ports Forwarded list as well. However, I get the same result. So it seems I still need help.

Solved my problem. I had mixed up two different Mac Minis on my network, and was port forwarding from the wrong one. Thanks for your support.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.