Roon Arc Not Working After Orbi Router update

Roon Core Machine

-Intel NUC Mainstream Kit (NUC8i7BEH) NUC8CY Tall with SAMSUNG 860 EVO SSD 250 GB -M.2 SATA WITH V-NAND TECHNOLOGY running Crucial 8GB SINGLE DDR4 2400 MT/S memory
Running ROCK

Networking Gear & Setup Details

Netgear RBR850 Orbi Tri-Band Mesh WIFI 6 Router

2 Orbi RBR850 Satellites

  1. Who is your internet service provider?


  1. Please list the make and model of your modem and router?

ubee Model No: UBC1302 cable modem

  1. Do you have any additional network hardware, like additional routers or managed switches?

Two switches: Netgear 6 port

S8Wpde Packedge 8 Port Gigabit Switch powered by PoE

  1. Does your network have any VPNs, proxy servers, or enterprise-grade security?

Connected Audio Devices

Google Chromecast
Apple TV

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

I tried to open Roon Arc while on my home WIFI and got a message that says “Roon Opitmized Core To connect, make sure your Roon Core is turned on and configured for remote access.

I can run Roon without any issues o my laptop and over the network. Just can’t get Arc to see the core.

I also get a message that says Arc cannot be used outside my network. I spoke to Netgear support and they made changes to the router and modem but Arc is still not working. They even attempted to activate the DMZ setting but that did not work either. I asked them to deactivate it because of the security risks. Feels like I am out of options. Arc worked prior to a Netgear Orbi update. The update allows me to see my network remotely from outside the home. I would hate downgrade and lose that capability. Please advise.

Please provide the diagnostics message, contained between the braces {…}, found under Roon > Settings > Roon ARC. Thanks.

From my iPhone I get a message in Roon Arc that says:

Roon Optimized…
Only available on your network

“To connect, make sure your Roon Core is turned on and configured for access outside of your network.”

When I go to Roon on my laptop and go to Settings/Roon Arc I see the following:
Ready Roon Arc can securely access your Roon Core

Roon Core IP



After several days of frustrating efforts to get Roon Arc to work I found a solution that might be helpful to others experiencing these issues. I contacted my ISP and requested a static IP address to counter the CG-NAT issue. That did the trick. There is an incremental monthly cost, but one that is well worth it to be able to use Roon Arc. My Orbi WIFI router automatically used the static address from the cable modem. I deleted and re-installed Roon Arc on my phone. It was able to access the ROCK while on my home network. I then turned off WIFI on the phone and Roon Arc was still able to connect over the cellular network and I no longer received the message that Roon Arc was not configured to work outside my home network. Hope that helps others in the community.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.