Roon Arc on D-Link GSL 225 & TP-Link Archer C2300

Roon Core Machine

Roon Rock runnig on a NUC

Networking Gear & Setup Details

Modem - D-Link GSL 225
Router - TP-Link Archer C2300

Connected Audio Devices

2 x Windows, 1 x Rooipee

Number of Tracks in Library

Description of Issue

Hi,
generally try to work things out myself but this ARC has got beyond me.

Initially did not work so mucked around with uPnP settings on both devices to no avail. Reconfigured router from an access point to a Router in admin and moved cable from LAN to WAN. This got a result - uPnP worked but I got the double NAT problem.

Managed to put the modem in bridge mode and the router direct - this worked and ARC functioned…but I lost the audio on my office computer and couldn’t get it back despite trying usual firewall stuff. Then the whole network crashed, Roon demanded logins and the internet went down - so no Roon anywhere - couldn’t get to local library at all.

A day later I got rid of the bridge on the modem and Roon works and internet back but no ARC.

Fiddled some more - read that using LAN rather than WAN to the router should be an effective bridge (what I originally had) but still getting the uPnP message again as attached screenshot.

Does this mean I have to set up manually - not sure how to do first step of setting fixed IP to ROCK…

cheers,
James

@James_Maude, I moved your post to the Port Forwarding area of Support. The devices you have:

Modem - D-Link DSL-G225
Router - TP-Link Archer C2300

are both routers, the D-Link G225 is a modem and a router, so you have the double-NAT issue. Can you get both devices back to their original settings? If so, can you set up UPnP on both routers, OR create identical port forwarding rules on both routers? I have AT&T Fiber and have an ASUS router behind the AT&T gateway, and needed to create port forwarding rules on both the gateway and ASUS router to get ARC to work properly.

On other question, do you have WiFi turned off on the DSL-G225? It may also be helpful to provide the information below so the community and Roon staff can improve our troubleshooting with you:

The port forwarding diagnostics you’ve provided suggest that UPnP is not properly configured on your router or not working correctly.
Please try the following steps in order:

  • Reboot your Roon Core and networking gear (router, modem, switches, etc.)
  • Try to enable UPnP/NATPMP in the web administration interface for the router
  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering
  • Try to update your router firmware
  • Check if your modem is in Bridge mode and if not, try to place into Bridge mode
    If you continue to experience difficulties, please tag the support team and include the following information:
  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?

@James_Maude hi there, did you ever resolve your Arc connection concerns here?

Hi,
not really and I had to give up for a bit.

Got the ROCK static IP and Port Forwarding working - I think - but it doesn’t fix the double NAT problem.

And while I got double NAT fixed briefly and ARC worked (modem in bridge mode), it crashed the rest of my network and I don’t know why. Each time I learn a little more though and I’ve got much quicker at resetting the routers!

Will have another go this weekend and then see if support can help me.
thanks,

Hi @James_Maude,

I too had an issue of my putting the modem into bridge mode totally crashing my network. It’s certainly not supposed to do that. I had to reach out to Xfinity and have them do it. They’ll assume that you’re doing something wrong so let them know up front that you’ve used your Xfinity app to do this and the results.

Let me know how it goes. I’m going to monitor our thread for a response and since I’ve had this same issue I’m particularly interested in the outcome!

Wes

1 Like

Hi @James_Maude,

Just checking in. Let me know where you stand and if you still need assistance!

Wes