Roon ARC on Qnap NAS with Sky Router

Roon Server Machine

QNAP NAS TS-451, running QTS 5.1.4.2596. Intel Celeron CPU J1900. Memory 8GB
Roon Server version: 2.0 (build 1353) Production. QPKG-Version: 2023-03-07

Networking Gear & Setup Details

Ethernet connected to Sky Hub Router Model # SR203 via D-Link 8 Port unmanaged switch (DGS-1008)

Connected Audio Devices

Linn Klimax DS connected via Ethernet.
Chord Poly/ Mojo2

Number of Tracks in Library

78,935

Description of Issue

Installed Roon on the QNAP without issue. The Linn, Poly and all other audio devices can all connect without issue. However, when I try to setup/ connect with the ARC in the Roon App, I get the “Not Ready” message with the following diagnostic information.

{
“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},

“external_ip”: {“actual_external_ip”:“90.aaa.bbb.ccc”,“actual_external_ipv6”:“null”,“router_external_ip”:“null”},

“natpmp_autoconfig”: {“status”:“NotFound”},

“upnp_autoconfig”: {“status”:“NotFound”} }

I followed the troubleshooter and have checked the Sky Router has automatic port forwarding enabled, and I have also followed the Sky instructions for manual port forwarding. I still cannot get the ARC to connect.

I am wondering if there could be an issue with the Qnap NAS blocking external connections to the NAS?

Any help and advise would be very much appreciated.

Many thanks

Andrew

Hello, just to add a note of a test I carried out.

I disabled the Firewall on the Qnap and was then able to access the Roon Server with ARC. I re-enabled the firewall on the Qnap while I look at solutions to allow access for ARC.

At least it has pointed me in the correct direction to look for resolutions!

Hello, issue has been resolved by adding a rule in the Qnap QuFirewall to allow access on the Roon Server Port.

2 Likes

Glad to hear it @Sof_Lee! You solved the case before support could assist you, but if you have any more issues, please open a new topic thread and we’ll be here.

1 Like