Roon ARC Port Forwarding Problem

Roon Core Machine

Intel NUC 12th Gen on Audiolinux OS

Networking Gear & Setup Details

Vodafone DE Vodafone Station
connected to an ASUS RT-AX92U via ETHERNET

ASUS RT-AX92U is connected to a Devolo Magic 2 Powerline
then the Powerline is connected to my Intel NUC where Roon Server is installed

Connected Audio Devices

DENAFRIPS ARES II

Number of Tracks in Library

50 tracks on SDD

Description of Issue

Can’t use Roon ARC

I’m getting this error:
{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“88.aaa.bbb.ccc”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.50.1”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/\” s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">718ConflictInMappingEntry</s:Fault></s:Body></s:Envelope>”}
}

Any idea how to solve this?

I have an ASUS RT-AX92U Router and I already tried to port forward the connection but to no avail.

UPDATE:

Opened Port Forwarding and Disabled uPNP on my router

New error appeared!!!

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“88.aaa.bbb.ccc”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}
}

Is your ISP supplied router in modem mode?

Could you complete this section and include your ISP.

Networking Gear & Setup Details

Hi @djnoctis,

The above might suggest you have uPnP activated and a port forwarding rule to the same port active at the same time. Try to disable uPnP if you don’t need it and keep the port forwarding rule to the port and IP address of your Roon core.
Hope this solves it.

Hi!

I have updated the networking gear and setup details

I did this and got a new error.

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“88.aaa.bbb.ccc”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}
}

This now indicated you have neither UPnP or a valid port forwarding rule set.

If setting a port forwarding rule in your router, you’ll need to input rules such as the below photo.

Out your Cores IP where mine is and the Port in the Arc settings tab in Roon.

So it’s:
Vodafone Station → Asus router → Devolo Powerline → NUC with Roon Server

When I look on the internet I see the Vodafone station is also a router with DHCP and NAT. Do you have it in Bridge Mode so all the traffic is routed directly to the Asus without NAT? If not, you have to also set a port forwarding rule in the Station to the address of the Asus router with the same Roon port.

1 Like

Whilst it’s possibly the cause, it’d normally show 2 external IP addresses.

The error is also saying

Which suggests no rules being set nor UPnP on.

With the Devolo set, are you connecting via WiFi on the one where the Core is. (repeater WiFi?)

I used LAN ports from the Devolo. It should mesh with the network built by the ASUS Router. I will try the suggestion of @Joost_Hoogland and will let you guys know. Thanks so much!

1 Like

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.