Roon Arc port foward error 504

Roon Core Machine

QNap 473a 8gb amd ryzen

Networking Gear & Setup Details

  1. Who is your internet service provider?
    UPC/Sunrise in Switzerland

  2. Please list the make and model of your modem and router?
    Upc 2g box

  3. Do you have any additional network hardware, like additional routers or managed switches?

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?

Connected Audio Devices

Weiss dac via ethernet

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“77.ddd.eee.fff”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“doaction request return statuscode: UnknownError”}
Upnp is on

Router on
I tried to do port fowarding , nothing error 504
turned firewall off in router nothing error 504
turned dnz on nothing

Do you have any suggestions?

Hi @m_giraldi,

What are the port number and IP-address shown in the Roon App under Settings → Roon Arc?


I found a reddit article detailing issues setting up port forwarding with this ISP. They had to call and get the ISP tech involved in opening ports. I would suggest giving the ISP a call, describing what you are doing and seeing how they can help. port 55002

Infact I partially did that by calling them to convert from ipv6 to ipv4…

1 Like

Hi @m_giraldi,

Could you try another port number? I read on this forum that some ISP block some port numbers. In the Roon App under Settings → Roon Arc change the port number to ie. 44135 and change your port forwarding and see if that’s working.

Hope it helps.

Kind regards,


1 Like

Hi @m_giraldi,

It sounds like you’ve contacted your service provider and requested a routable IPv4 address. Your account diagnostics seem to confirm that your external IP is in this format. Provided there’s not an additional layer of carrier-grade NAT in play here, then I suggest you 1) restart your router/modem and all networking equipment, as well as your Core and then 2) try changing the port number in Roon → Settings → ARC as @Maarten_Duits helpfully suggested.

If that isn’t successful, please try disabling UPnP (if you’re setting a manual rule, you won’t need autoconfiguration via UPnP).

We’ll keep an eye out for your response.

1 Like

Thank you for the suggestion. Actually I was able to solve the problem by changing the setting of the Qnap internal firewall. Practically the router settings were blocked by the Qnap firewall, I just replicated the port forwarding setting in the Qnap firewall. Problem solved.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.