Roon ARC reports poor connection

I am running Roon on NUC Rock core with Mac and iPhone remotes. ARC works fine in the house, but it never plays anything from the iPhone’s cellular connection, reporting a poor connection. I live in a major metropolis with good 5G reception. My plan has unlimited full-speed cellular data. Am I doing something wrong? Thank you.

Roon Core Machine

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

5 Likes

Similar thing happened to me. However, it did play several minutes at first …
but then got ‘poor connection’ issue and playback stopped :frowning:

Try shutting off Wi-Fi on the phone? Or maybe turn the mobile data setting off and on again as well? I saw a handshake issue in ARC every now and again when the phone would switch data usage between Wi-Fi and cellular during testing. Usually either of those 2 tricks would clean up the stream.

1 Like

I get that most every time now when I’m on ATT cell service. Works perfectly on WiFi.

Is there something on the network side that needs to be changed to allow for access via public cell service?

2 Likes

I get the same issue all the time on the mobile data. Never been successful using it on the go so far.

I have Roon running on my MacBook Pro as a core. I was testing yesterday, and it works fine as long as you are on the MBP but I noticed that if you stop using the laptop and it goes into screen saver mode arc stops working, or if you set the laptop to “screen never off” and turn off screensaver it will still stop working after a while. Arc stops connecting unless the MBP is fully awake like it’s in use.

The funny thing is regular Roon works just fine no matter if the screensaver kicks in or not, or even if the screen turns off Roon still works on Wi-Fi. Only ARC has the issue.

Just wanted to pass this information on to you guys since I was messing around last night testing this.

So tried this again … started playing something while car was in garage (wifi connected).
After a few meters, wifi disconnected and cellular signal took over. Playback was still
fine then. Reached my destination (maybe about 6 miles) and stopped playback. When
I got back to car, I continued playing the same song that was playing last time … this time
playback did not work due to “poor connection”. So I terminated roon arc, off/on cellular signal
(even tried airplane mode on/off), and then restarted roon arc. That did not help. I then
tried Qobuz app and it played just fine. Then tried roon arc again … nope still not working (BTW
I am still parked and did not drive off). So it seems its not a signal connection issue. Most
likely something in the app or the server?

Is there WI-Fi on in the vehicle or an open Wi-Fi signal close enough so that the phone is trying to make both connections (Wi-Fi and cellular) with the same app (ARC) at once? Once you opened Qubuz, you opened a brand-new app after the phone already established a connection so there was no need for it so search for either a Wi-Fi or cellular connection as ARC had to do on it’s initial start-up.

No wifi in vehicle but not sure if there were any near the area. Note that I tried roon arc
again (terminated it before running qobuz) after trying qobuz and same issue observed.

I did catch the ARC usage after it being terminated and restarted with the same resulting connection issue. Let me explain why I thought what I said was relevant.

My particular issue was because my house is in a cellular dead zone, so to accurately test the connection of ARC to the Core during initial testing I needed to use Wi-Fi until I cleared the dead zone and pick up the local cell signals. It was when I returned home and noticed the phone had switched to my Wi-Fi connection but was reporting a poor connection error. Looking at the connection icons at the top of my phone screen I could see traffic happening on the cellular connection but not much going on with the Wi-Fi icon which showed 100% connection to the wireless network in my house. So, on a whim I shut off the mobile data setting on the phone and within a couple of seconds the stream cleared up and resumed proper playback over Wi-Fi. I had this happen every time until I go into the habit of shutting off the Wi-Fi on my phone before I launched ARC and went for a drive.

Just hoping I’m not making things worse for you.

I get this when trying to play an album which is stored locally in my Nucleus.
In my view this is due to the low upload bandwidth of my home internet connection. So this is not a problem roon can fix.
All albums which are from Qobuz play without problem. But my nucleus stored albums get this “slow connection” problem.

Or maybe just a handshake issue switching from Wi-Fi data usage to cellular data usage, and vice versa? And maybe on just certain handsets/OS/settings? It’s all very difficult to determine without access to view the complete network mapping to any one single persons’ connection to their Core.

Update:

This is working for me now. Here is what I did:

In my roon core: went to settings/roon arc - I forcibly refreshed to
retest the roon arc connection. After this, so far, I haven’t experienced
the ‘poor connection’ issue.

That’s great to hear. All of these network issues will get ironed out as more and more hardware configurations join the mix. It’s a shame there really isn’t a way to test every single hardware configuration before release, because that’s just impossible to do.

I had the poor connection issue (WiFi was turned off as it should be when remote). I turned off Cellular Data and turned it back on it started working!

I had the same issue. Turned off cell data went to Wifi only.

Bingo! It worked. I’m in a poor cell zone area.

Samung S10+, 4g LTE

Will try cell method next time I’m in the “big city”. :smile:

Hi everyone,

Thank you for your patience while we’ve worked through the queue of ARC-related issues with the release of Roon 2.0.

Note that ARC will require port forwarding to be configured on your home network in order for 4G/5G playback to work. In many cases, you will see that has been configured automatically in Roon → Settings → ARC. I recommend you take a look at this article: Help Center: Port Forwarding Guide

Depending on your internet service provider, your router, and your home network, automatic configuration of port forwarding might not work, and you’ll have to take some extra steps to configure port forwarding manually, most commonly by accessing the web administration page of your router, modem, or both.

The support team would be happy to assist you. In any case, I recommend looking at the message listed in the ARC tab in Roon → Settings, as it will provide immediate next steps for support. Also, take note of the make and model of your router, and then see if there’s an existing set of solutions in our List of Known Router and ISP Solutions here.

Lastly, if you need assistance with port forwarding, please start your own topic thread in the #support:port-forwarding-help subcategory, as we’ll be able to assist you more promptly if we can see you issue in its own dedicated thread.

Yes, I am having almost exactly the same issue with ARC. The crazy thing is that it sometimes does work fine on cellular data–but only perhaps 1 out of 5 times when I leave WiFI range.

1 Like

Me too. I’ll have another look at this when I get a minute.