Roon ARC setup issues. sig Mikrotik router and getting error messages

Roon Core Machine

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“103.aaa.aaa.bbb”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}
}

Hi,
You can get your mikrotik to export settings that give information for us to help you.

E.g.:
/ip firewall filter,
/ip firewall nat
/ip addresses
These give usefull info
or do global export of the whole mikrotik config.
Remember to exlude sensitive info when doing a global export of the config if you post it :slight_smile:

Relevant info can make us help you.

I use mikrotik routers and have them working with no issues when listening to ARC

When i have the time later in the day, i can post relevant config items.
Note, that here are a lot of different MikroTik routers so post your type and ROS version.

1 Like

hex S
Model RB760iGS

Have tried setting up Upnp and NAT in firewall settings, but no luck.

Networking Gear & Setup Details
Mikrotik Hex S
SFP connection to Roon via Etherregen Switch

Connected Audio Devices
Roon Nuclues → Devialet Expert Pro 1000

Number of Tracks in Library
4300

Description of Issue
Can’t router to talk to Roon Nucleus fro ROON Arc

Hei Allan,

Please post more information on the actual config and ROS version.
MikroTik routers can be configured in a lot of ways, so please:
State the version of your ROS and post relevant or (best of all) the complete configuration.
Eg. Use / export file=myrouter hide-sensitive
Or post info from e.g. relevant section like: /ip firewall nat pr and /ip address pr
But the more we see of your config the better we can help.

As of now i will not do anything until i have relevant information.
MikroTik has a very good diagnostics toolset but you must be willing to use and share.
EDIT: The MikroTik RouterOS is professional enterprise grade and is really a swiss army knife that can be used and configured in thousands of different ways, also in wrong ways!!!

My home router :

       routerboard: yes
        board-name: hEX S
             model: RB760iGS
     serial-number: XXXXXXXX
     firmware-type: mt7621L
  factory-firmware: 6.46.3
  current-firmware: 6.49.7
  upgrade-firmware: 6.49.7

This is output from /system routerboard pr

version: 6.49.7 (stable)

This is partial output from /system resource pr

The diagnostics you’ve provided suggest that UPnP is not properly configured on your router.

Please first try the following steps:

  • Try to enable UPnP/NATPMP in the web administration interface for the router directly upstream from your Core
  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering
  • Check if your modem is in Bridge mode

If you continue to experience difficulties, please tag the support team and include the following information, as requested by @PeterD:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?

ARC can be configured with two configuration commands on RouterOS, if the prerequisites are met.
Although ROS supports UPnP i would not choose to use it.
A Mikrotik router is a professional complicated device and you have to know how to use it.
Using it the wrong way can cause serious networking problems or unsafe behaviour.

The above disclaimer is why i do not post the relevant commands to enable ARC, as that potentially can harm Allans configuration.

board-name: hEX
Smodel: RB760iGS
serial-number: E2090ED92C2C
firmware-type: mt7621L
factory-firmware: 6.46.4
current-firmware: 6.47.9
upgrade-firmware: 6.49.7

System resource…
version: 6.49.7 (stable)
build-time: Oct/11/2022 14:37:24
factory-software: 6.46.4
free-memory: 215.2MiB
total-memory: 256.0MiB
cpu: MIPS 1004Kc V2.15
cpu-count: 4
cpu-frequency: 880MHz
cpu-load: 1%
free-hdd-space: 4692.0KiB
total-hdd-space: 16.0MiB
write-sect-since-reboot: 1324
write-sect-total: 93766
bad-blocks: 0%
architecture-name: mmips
board-name: hEX S
platform: MikroTik

Router is in router mode

Router is connected to Internet using PPPOE
Provider Lightning Broadband
Australia

NAT Enabled for Roon Nucleus
Chain = dstnat
Protocol = TCP
Port = 55000 (Roon Nucleus set to 55000)
Action = dstnat
To Adddresses = 192.xxx.xxx.xx (Ron Nucleus)
To Ports = 55000

PORT forwarding enabled

/IP Firewall nat
0 ;;; defconf: masquerade
chain=srcnat action=masquerade out-interface-list=WAN ipsec-policy=out,none

1 chain=srcnat action=accept log=no log-prefix=“”

2 chain=dstnat action=accept log=no log-prefix=“”

3 ;;; ROON ARC
chain=dstnat action=dst-nat to-addresses=192.168.0.22 to-ports=55000 protocol=tcp in-interface=bridge dst-port=55000 log=no
log-prefix=“”

/IP Adresses

ADDRESS NETWORK INTERFACE

0 ;;; defconf
192.168.0.1/24 192.168.0.0 bridge 103.156.156.111/32 103.247.3.44 pppoe-out1

Remove in-interface=bridge or change it to the correct wan interface.
Your wan interface has to be where the internet traffic is comming in.

There is no output information for the /ip address pr command, that would be usefull.
It gives a list of ip addresses on the respective interfaces that need to route/switch the traffic.
Just a side question, is your wan ip a routable ip address that is not NATed by your provider?

Please provide export of your COMPLETE configuration.

Here is a dump of the config

oct/30/2022 11:06:05 by RouterOS 6.49.7

software id = VSM5-K4HS

model = RB760iGS

[Private Information Removed by Moderator for User Safety]

/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=dhcp ranges=192.168.0.2-192.168.0.254
/ip dhcp-server
add address-pool=dhcp disabled=no interface=bridge name=defconf
/interface bridge nat
add action=accept chain=srcnat
add action=accept chain=dstnat
/interface bridge port
add bridge=bridge comment=defconf interface=ether2
add bridge=bridge comment=defconf interface=ether3
add bridge=bridge comment=defconf interface=ether4
add bridge=bridge comment=defconf interface=ether5
add bridge=bridge comment=defconf interface=sfp1
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface detect-internet
set detect-interface-list=all
/interface list member
add comment=defconf interface=bridge list=LAN
add interface=pppoe-out1 list=WAN
/ip address
add address=192.168.0.1/24 comment=defconf interface=bridge network=
192.168.0.0
/ip dhcp-client
add comment=defconf interface=ether5
/ip dhcp-server lease
add address=192.168.0.22 client-id=“Roon Nucleus” mac-address=
94:C6:91:11:EC:62 server=defconf
/ip dhcp-server network
add address=192.168.0.0/24 comment=defconf gateway=192.168.0.1 netmask=24
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.0.1 comment=defconf name=router.lan
/ip firewall filter
add action=accept chain=input comment=
“defconf: accept established,related,untracked” connection-state=
established,related,untracked
add action=drop chain=input comment=“defconf: drop invalid” connection-state=
invalid
add action=accept chain=input comment=“defconf: accept ICMP” protocol=icmp
add action=accept chain=input comment=
“defconf: accept to local loopback (for CAPsMAN)” dst-address=127.0.0.1
add action=drop chain=input comment=“defconf: drop all not coming from LAN”
in-interface-list=!LAN
add action=accept chain=forward comment=“defconf: accept in ipsec policy”
ipsec-policy=in,ipsec
add action=accept chain=forward comment=“defconf: accept out ipsec policy”
ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment=“defconf: fasttrack”
connection-state=established,related
add action=accept chain=forward comment=
“defconf: accept established,related, untracked” connection-state=
established,related,untracked
add action=drop chain=forward comment=“defconf: drop invalid”
connection-state=invalid
add action=drop chain=forward comment=
“defconf: drop all from WAN not DSTNATed” connection-nat-state=!dstnat
connection-state=new in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat comment=“defconf: masquerade”
ipsec-policy=out,none out-interface-list=WAN
add action=accept chain=srcnat
add action=accept chain=dstnat
add action=dst-nat chain=dstnat comment=“ROON ARC” dst-port=55000
in-interface=bridge protocol=tcp to-addresses=192.168.0.22 to-ports=55000
/ip upnp
set allow-disable-external-interface=yes enabled=yes
/ip upnp interfaces
add interface=ether2 type=internal
add interface=ether1 type=external
add interface=sfp1 type=internal
add interface=ether3 type=internal
add interface=ether4 type=internal
add interface=ether5 type=internal
/system clock
set time-zone-name=Australia/Melbourne
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN

 ;;; Roon ARC
chain=dstnat action=dst-nat to-addresses=192.168.0.22 to-ports=55000 protocol=tcp dst-port=55000

In your config you did not change the nat rule as i proposed.
Delete the one you have or disable it an put the one above there instead, test and report back.

Did you add those? They are not needed.
Disable them while testing.

Disable all upnp config while testing.

Did the recommended changes, the Nucleus reports that I am set up for ARC.
Much to my surprise!
Thanks so much

:partying_face:
Good to hear it is working.
Cheers, Peter

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.