Roon ARC Setup on ASUS Router

Another dummie here

I’ve tried setting forwarding in my ASUS router, but it doesn’t seem to work here either.

@SandsOfArrakis, I moved and created a new port forwarding support thread for you as you and the OP have different routers and the instructions may not be identical. In your case, it appears you have two routers in your network based on the error message.

The diagnostics you’ve provided suggest that UPnP is not properly configured on your router.

Please first try the following steps:

  • Try to enable UPnP/NATPMP in the web administration interface for the router directly upstream from your Core
  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering
  • Check if your modem is in Bridge mode

If you continue to experience difficulties, please tag the support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?
2 Likes

I have indeed 2 routers. One is build into the mediabox that my ISP (Ziggo) provided. It handles both TV and Internet. My ASUS router is connected to the Ziggo router through an ethernet cable connected to one of the ethernet ports. The ASUS router connects the rest of my hardware through its wifi.

Directly upstream as in the Ziggo router or the ASUS one?

The Ziggo router has UPnP enabled.

On my ASUS router, model is in the screenshot, I have setup a forwarding port. I hope I’ve done this correctly. The source IP is the IP address of the Ziggo router, the local IP address is from the MacBook Air containing the Roon Core.

Edit.

As a test, I’ve connected my iPhone and both my MacBooks, one of which contains the Roon Core directly to the Ziggo router. This is the one that has the direct connection to the Internet.

After reserving an IP address for the Roon core, and setting the forwarding here

Then I receive this message

So here it works.

Now to see how to get the 2 routers to connect properly. I can’t seem to put the ISP router into bridge mode myself. As I’m getting a warning that it can only be done remotely. I haven’t tried that yet.

Well I can’t seem to get my ASUS router to forward the required ports to get ARC running. But connected directly to the ISP’s mediabox’s router it works like a charm. So I have moved my devices to the wifi of my ISP’s router.

Tested the whole thing with my iPhone at home, with its wi-fi turned off. And it happily connects and plays music through my 4G connection.

Tomorrow it’s back to work, so I can do a proper stress test. But so far it seems to have been fixed as far as I’m concerned.

1 Like

Glad to hear you are up and running with ARC. If you are comfortable with the quality provided by the Ziggo Mediabox, excellent. If you want to re-introduce the ASUS router for any number of reasons, we should be able to help you with configuring both the Mediabox and ASUS routers to support port forwarding (or UPnP). I have an AT&T gateway in front of my ASUS router and run ARC with port forwarding on both.

Well I might have to go down that rabbit hole sadly. Today wifi dropped 3 times all over the board for a few seconds with the Ziggo Mediabox. I have never noticed the ASUS wifi just dropping randomly.

Most ISP routers are older or not as robust as what you can purchase at retail. Part of the reason why I use my ASUS router for all my LAN traffic and leave my AT&T gateway as basically a connection between my fiber and my ASUS.

Are you able to activate either UPnP on your Mediabox or create a port forwarding rule on it?

1 Like

UPnP is enabled by default as I have screen shotted earlier in this topic. So that’s good. The UPnP part also took care of the forwarding part by setting the port forwarding in the Mediabox correctly.

Currently connected to the Mediabox are my 2nd router through Ethernet. The rest connect through wifi. My iPhone, my 2 Harman Kardon Citation One speakers who form a Chromecast pair and my MacBooks (Amaterasu & Athena). Athena holds the Roon Core.

Not that many devices my guess.

So my guess is how to get the ASUS and Ziggo Mediabox to talk to each other. Everything else works fine with the ASUS when everything is hooked up there. Only ARC doesn’t want to play.

If that Mediabox didn’t at random sometimes looses wifi for a few seconds it would have been perfect. I went for a walk for an hour and ARC played without hiccups all the way.

So as I understand ARC, you should have either 1) UPnP enabled on both your Mediabox and ASUS routers, OR 2) port forwarding rules must be created, with the Mediabox forwarding to the ASUS and the ASUS forwarding to your Roon Core computer.

Does that forwarding to the ASUS router happen through port triggering?

I’ve checked the ASUS router. And UPnP is also enabled on it.

So both routers have UPnP enabled. Yet ARC doesn’t seem to want to work with the ASUS as connected router.

I’ve made a new forwarding rule. The IP on top is the one that the ASUS router receives from the Ziggo Mediabox.

I am not sure how the Mediabox is configured, but you will need the IP address of the ASUS router and the Roon ARC port number shown in Roon’s Settings → Roon ARC tab.

Typically for most two-router networks, the Mediabox should forward a TCP port using the Roon ARC port number to the IP address of the ASUS router. (similar to post #7 here, the IP address of the port forward should be the IP address of the ASUS router).

In the ASUS router, you need to create a TCP port forwarding rule pointing to the Roon Core computer using the Core’s IP address and the Roon ARC port number (similar to what you have in post #2). UPnP should be off/de-activated on both routers to make sure it does not interfere.

Ok added a rule which I’ve screen shotted in my previous message, and that led to this

Disabling the new rule makes ARC work again.

Ok, I have disabled UPnP on both my routers.

On the Ziggo Mediabox I have created this rule

192.168.178.66 is the IP address the Ziggo router has assigned to the ASUS router. It was easy to check for me since it is the only one that is connected through Ethernet. TCP/IP port is 55000 and I have enabled it.

I’ve created this rule on my ASUS router. As source IP I’ve picked 192.168.1.1 as it’s the IP address the ASUS router uses for itself on its own network. 192.168.1.68 is the IP address of the Roon Core. And it uses TCP/IP port number 55000. I take it port range also has to be 55000?

With this setting it doesn’t work.

So what am I doing wrong here?

Hi @SandsOfArrakis,

I have almost the same setup with a Ziggo modem and a Asus router.

In the port forwarding rule in the Asus you don’t need to enter a source ip. If you leave that empty it will probably work.

Cheers,
Joost

3 Likes

Wow man. That seems to have done the trick.

Now to test it out.

And it works.

Thanks man :star_struck:

Cheers,
Erwin

2 Likes

You’re welcome. You might want to set up a ip address reservation in your Ziggo modem for the address of your Asus router to keep that set at all times.

You can find that under Advanced settings → dhcp

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.