Roon ARC setup on Sky Router

Roon Core Machine

Roon Rock

Networking Gear & Setup Details

Sky Router with Orbi mesh

Connected Audio Devices

Devialet - Roon Ready

Number of Tracks in Library

Description of Issue

I am unable to setup Roon Arc to connect from outside the home. I have tried following the Troubleshooting but still have the same problem. Any advice gratefully received! Here is the diagnostics message:
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“actual_external_ipv6”:“null”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="\” s:encodingStyle="\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">501ActionFailed</s:Fault></s:Body></s:Envelope>”}

The diagnostics you’ve provided suggest that UPnP is not properly configured on your router, and the reason for this is most likely because you have a redundant layer of networking introduced by the Orbi mesh.

From experience, I know that the Sky router will be configured automatically using UPnP. However, in your case, you’ll need to set up port forward manually because you have two subnets, i.e., that provided by your Sky Hub, and another by the Orbi.

In the Sky router, set up a manual port forwarding rule that opens port 55000 (or what is displayed under Roon > Settings > Roon ARC), and add the Orbi’s IP address. Note: the Sky Hub doesn’t support bridge mode.

Then, open the Orbi administration screen and setup port forwarding to your Roon core. Both should use the same port.

All devices should be connected to the Orbi.

1 Like

Thanks very much for the advice Martin. I’ll give that a try.

1 Like

Hey @Darren_Elding,

I wanted to check in on this thread to see if @Martin_Webster’s helpful reply led you to a solution?

I’ll be on standby for your reply. :pray:

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.