Roon ARC through Deco mesh

Im using a tplink deco mesh network and cant work out how to get arc working. It used to work without deco mesh in orevious property. But now needs to go through mesh network but wont auto configure and not sure how to manually setup. Have tried but no luck

Please share the diagnostic message found in Settings > Roon ARC.

Most likely, you have a double-NAT arrangement now with two subnets caused by two routers.

The original router should forward to the Deco (and your core should be connected to this), and the Deco should forward to the core.

There is a router going into one deco x75 followed by a second deco x75 which is connected to my roon rock via ethernet.

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“93.aaa.bbb.ccc”,“actual_external_ipv6”:“fe80::AAAA:BBBB:CCCC:DDDD:9cc9”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}
}

Any help would be appreciated

@Matthew_Jones, the diagnostics you’ve provided suggest that UPnP is not properly configured on your router.

Please first try the following steps:

  • Try to enable UPnP/NATPMP in the web administration interface for the router directly upstream from your Core
  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering
  • Check if your modem is in Bridge mode

If you continue to experience difficulties, please tag the support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?
1 Like

Hi @Matthew_Jones,

When i look at your error message, i also see an external ipv6. Is IPV6 enabled on the mesh? If so, could you disable it? As far as i know ipv6 is not (yet) supported by Roon.

Also check, as @Robert_F mentioned if UPnP is enabled.

Regards,

Maarten.

1 Like

Could this issue be caused by the mesh satellite having a different IP address than the actual mesh router?

I have a similar setup and issue using a Netgear Orbi router and satellite. My ROCK is wired to the Orbi satellite which communicates wirelessly to the Orbi router. The router and the satellite have different IP addresses.

I’ve configured port forwarding for the IP address associated with the ROCK, but since it goes through the satellite I think something gets lost in translation. UPnP is enabled on the router. Neither auto configuration via Roon nor manual port forwarding resolve the issue. I can’t connect ROCK directly to the router due to wiring constraints.

@Robert_Siegel, can you expand on what you mean by the router and satellite having idfferent IP addresses? They each should have unique LAN IP addresses (such as 192.168.1.1 and 192.168.1.2) but they should both have idential three first sets of numbers in their addresses (in this case 192.168.1.aaa) with only the "aaa: being unique to each device.

Or do you mean that all of the numbers, or the last two sets or numbers in their addresses are different?

Yes, my router is .1 and my satellite is .2. ROCK is .4.

Since my port forwarding is between the router and ROCK, I was wondering if the satellite is “getting in the way” so to speak.

I know next to nothing about network setup…

@Robert_Siegel, no worries, this looks correct. My recommendation is to disable UPnP on the routers and just use the port forwarding rules you created. Can you post a screenshot of the port forward rule you created on the Deco router?

Thanks Robert. I tried disabling UPnP but that didn’t resolve the issue. I’ll open a new thread and post all my settings rather than hijacking this thread completely.

1 Like