Roon ARC unable to access Roon Server

Roon Server Machine

for iPad with Roon Remote: iOS 17.1.2, iPad Pro (10.5 inch)
for Windows PC: Windows 11, 13th Gen Intel(R) Core™ i7-13700 2.10 GHz, 16 GB RAM

Networking Gear & Setup Details

  1. Who is your internet service provider?
    Spectrum

  2. Please list the make and model of your modem and router?
    Netgear Docsis 3.1 GB moden
    Netgear Nighthawk R8000 X6 AC3200 router

  3. Do you have any additional network hardware, like additional routers or managed switches?
    no

Proton VPN, which I have switched off without effect for this issue
4) Does your network have any VPNs, proxy servers, or enterprise-grade security?

Connected Audio Devices

image

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

I have confirmed that my router is using UPnP, as the troubleshooting steps call for, but I still get this error message, so I can’t use ARC:

FYI, the Roon ARC screen shows the correct Roon Server IP address. It automatically shows use of Port 55000. I don’t know if changing the port would help, and I don’t know to what it should be changed.

I’d like to use ARC.

My router in general uses dynamically assigned IP addresses, and for security reasons I very much don’t want to change that unless it’s the only way to solve the ARC issue. However, the PD address for my Nucleus always shows up the same

IP, not PD

Hi David,

The error message states that

{“actual_external_ip”:“xxx.xx.xxx.xxx”,“router_external_ip”:null}, “natpmp_autoconfig”: {“status”:“NotFound”}, “upnp_autoconfig”: {“status”:“NotFound”} }

Which usually means the Router’s UPnP is not on. First verify that you are not using any VPNs on the PC which is also running RoonServer. If so, disable the VPNs and see if things change.

Also, below is from the ARC Port Forwarding Troubleshooting FAQ for your error message:

Try the following

Turn on UPnP on your router and try to run Roon's port forwarding test again.
Try to set up manual port forwarding in your router.
   Make sure the IP/Port matches in any port forwarding rule you create.
Double-check to make sure you don't have any VPNs, Firewalls, or other network filtering software blocking Roon.
Check if your modem is in Bridge mode.
Restart your network hardware and update firmware.

Additional Notes:
This error often results from VPNs interfering with UPnP and NATPMP.

1 Like

Hi @David_Taylor,

In addition to our helpful moderator @Rugby’s comments above:

If you enter the router’s web GUI and see that UPnP has been disabled, I would verify that there aren’t any router firmware updates pending for your device. If there are updates, I’d recommend installing those before attempting another automatic configuration of port forwarding.

Router firmware can sometimes restrict the network activity of UPnP if it’s not up-to-date.

If you enable UPnP successfully but receive another diagnostic message in Settings → ARC, please paste it here.

Dynamic IP address assignment isn’t a problem in a stable network with simple topology and standard DHCP settings. As long as your router can retain sight of the Nucleus, it can pass that IP address correctly to the phone.

What could potentially block port forwarding would be Carrier-Grade Network Address Translation (CG-NAT) on the part of your ISP - this would scramble your external IP address upstream of the router, blocking a connection to ARC. If you continue to encounter errors in diagnostics, it’s worth contacting your ISP to verify if they have CG-NAT in place.

1 Like

Thanks for the helpful tips. My ISP is Spectrum, and I’ve verified that it does not use CG.NAT. I get a public IP address for my Nucleus starting with 192, not a CG-NAT address starting with 100. My Netgear router firmware is up-to-date (I checked). It has UPnP enabled (I also checked). My RoonServer is my Nucleus - it is not on a PC. The Nucleus is directly connected by Ethernet to my router and modem. So I believe my RoonServer is not being affected by VPN. I do normally run ProtonVPN on my iPad which serves as my Roon Remote, but I have tried turning ProtonVPN off on the iPad and that does not help.

I don’t know how to turn on manual port forwarding on my router. If I try to figure that out, I’ve no idea what port I should specify.

I also don’t know how to determine if my modem is in bridge mode, and don’t know whether ARC wants the modem to be in bridge mode or not.

192.168… addresses are not public they are always private internal network addresses. So, if you look at the
Capture

The RoonServer IP is the internal network IP not a public IP. Your external IP begins with 174 and is highlighted in the error diagnostic section.

Are you using Proton VPN? VPN use can cause issues.

Just to be clear, this is NOT a public IP address (i.e. publicly visible out on the internet); it is an address that is inside of your home network, visible only to devices on your home network that are also within the address space of 192.x.x.x.

1 Like

I use ProtonVPN, but it only affects my iPad which is my Roon Remote. My Nucleus is connected directly by Ethernet to my Nighthawk router and modem. In addition, I’ve tried this with ProtonVPN turned off, and that makes no difference.

I’m not sure what the consequence is from my public IP address starting with 174. Is there something I need to do because of that?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.