Roon Arc unable to connect to Roon core running Google wifi mesh

Roon Core Machine

Intel NUC running latest ROCK version
Operating System
Version 1.0 (build 256) production
Roon Server Software
Version 2.0 (build 1202) production

Networking Gear & Setup Details

  • GPON HG6240A modem with Fiber internet connection.
    Modem is NOT running in bridge mode but router mode.

  • Google Wifi Mesh with 1x router and 2x nodes (Local LAN/Wireless)

  1. Who is your internet service provider?
    ViewQuest FiberHome (Singapore)

  2. Please list the make and model of your modem and router?
    Modem - GPON HG6240A (Also a router)
    Router - Google Wifi Mesh with 1x router and 2x nodes

  3. Do you have any additional network hardware, like additional routers or managed switches?
    Router Google Wifi Mesh with 1x router and 2x nodes

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?
    N.A

Connected Audio Devices

Roon Ready Hegal Amp service as streamer and DAC

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

Modem is serving as router and NAT (192.168.79.x)
Router is Google Wifi Mesh serving as router (192.168.86.6.x). I cannot run Google Wifi in bridge mode as i need to connect additional 2x Google Wifi nodes for wifi coverage.

Roon core and end point are in 192.168.86.x subnet and they are working well locally

I have performed port forwarding on the modem to allow google wifi router (192.168.79.2) 55000-55005 port range.
On the router end, i have also allowed 55000-55005 port range

I am getting the following error;

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“137.ddd.eee.fff”,“actual_external_ipv6”:“null”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}
}

Does double NAT work for Roon ARC setup or the modem must be in bridge mode? Please advice.
Thanks

Either have cascading port forwarding rules, router 1 to router 2 and router 2 to server.

Or, put one on bridge mode.

Thanks for replying.

Some information about my router 1 and router 2 setup

Router 1 = ISP modem
IP address: 137.x.x.x (WAN IP)
IP address: 192.168.79.254 (LAN IP)
DHCP leasing range: 192.168.79.2 - 192.168.79.50

Router 2 = Google wifi router
IP address: 192.168.79.2 (WAN IP)
IP address: 192.168.86.1 (LAN IP)
DHCP leasing range: 192.168.86.2 - 192.168.86.200

Roon core
IP address: 192.168.86.55 (Static IP)

If i want to do cascading port forwarding, what is the IP address i should use on router 1 for port forwarding?
I am using 192.168.79.2 atm

Router 2 which is the google router naturally will be using the 192.168.86.60 (roon core) for port forwarding.

I am still getting the below error;

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“137.aaa.bbb.ccc”,“actual_external_ipv6”:“null”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.86.1”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/\” s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">718ConflictInMappingEntry</s:Fault></s:Body></s:Envelope>”}
}

Hi @Bee_Hive,

You want to create an identical port forwarding rule in both routers, pointing to the static IP (Core IP) and listening port listed in Roon → Settings → ARC.

The diagnostic message you’ve posted includes a ConflictinMappingEntry trace - this means there is another service using the same port number as Roon on this network. Usually, this is another streaming or gaming software, the router’s own firewall, or your internet service provider’s carrier-grade NAT.

If the manual port forwarding rules don’t work, then it’s worth verifying you don’t have a VPN or firewall interfering here, and also checking if your ISP has ports reserved.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.