Roon ARC was unable to access Roon Core

Roon Core Machine

Intel NUC i7
Roon Core OS Version 1.0 (build 227) stable
Roon Software Version 2.0 (build 1133) production
2000GB, Samsung SSD 860
Synology RS 815 NAS

Networking Gear & Setup Details

See LAN Overview PNG
DrayTek 2862 Firmware 3.9.9_BT (latest)
Ubiquiti UDM Pro (latest)
Ubiquiti Pro 24 PoE Gen 2 (latest)
BT Wholesale SoGEA VDSL (Static IP)

DrayTek is used in non-Bridge Mode to facilitate Work VPN Backup to Synology NAS on Port 1
DrayTek Firewall Rules Active
DrayTek Port 55002 Throughput Rule Active
DrayTek Port Forward for UDM Pro Active
DrayTek connected to UDM Pro which acts as Home LAN DHCP Server & Firewall
UDM Pro Port Forward for Roon Rock Active
UDM Pro Firewall Rules Active
UDM Pro Port 55002 Throughput Rule Active

  1. Roon on home LAN is working perfectly on all devices
  2. Roon ARC on home LAN is working perfectly on iPhone 13 Max Pro
  3. I have tried with UPNP functional on both DrayTek and UDM Pro and there is no difference no matter what combination I use
  4. I have tried disabling all Firewalls on both DrayTek and UDM Pro again to no avail
  5. Ports are Manually Forwarded on both DrayTek to UDM Pro and from UDM Pro to Roon Rock
  6. Hi-Fi System & Roon Core are connected directly to UDM Pro RJ45 Port & UDM Pro direct to DrayTek all via CAT 6 i.e. rest of LAN all downstream

It appears that within Settings/Roon ARC this determines Listening’ Port as 55002, (for my setup), yet this Port does not appear on an Open Ports Scan, how does this Port get designated please?

I am at a loss as to where the fault lies, even a very much more experienced person than myself has looked and cannot fathom either :-0>

  1. Who is your internet service provider?
    BT Wholesale SoGEA VDSL (Static IP)

  2. Please list the make and model of your modem and router?
    DrayTek 2862 Firmware 3.9.9_BT (latest)

  3. Do you have any additional network hardware, like additional routers or managed switches?
    Ubiquiti UDM Pro (latest)

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?
    DrayTek VPN (Work)
    DrayTek Firewall Rules Active - DrayTek Port 55002 Throughput Rule Active
    UDM Pro Firewall Rules Active - UDM Pro Port 55002 Throughput Rule Active

Connected Audio Devices

a) USB Cable from Roon Rock to Cyrus X-Stream Signature within main Hi-Fi System at home
b) CAT6 LAN from Roon Rock via Ubiquiti Switches to various Sonos Speakers within home
c) All Ubiquiti Switches & WAP’s within home
d) All hardware running latest Firmware - Ubiquiti Network OS Version 7.2.95

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

ARC Test - Cannot Connect to Roon

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“doaction request return statuscode: UnknownError”}

Welcome to the Roon community, @Tim_Parr.

The diagnostics you’ve provided suggest that UPnP is not properly configured on your router.

Please first try the following steps:

  • Try to enable UPnP/NATPMP in the web administration interface for the router directly upstream from your Core
  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering
  • Check if your modem is in Bridge mode

If you continue to experience difficulties, please tag the support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?

Martin, thanks for reply but all the above have been attempted or are currently in force, I am not trying to be rude nor clever, but I included all info and screenshots answering all of the questions above in my original post

As neither the UPNP on the DrayTek or the UDM Pro appear to help the situation the Ports have been Forwarded manually.

The Roon listed Port 55002 is as per the Settings/Roon ARC, however I would like to understand how is this specific Port No. is arrived at please?

How do I tag ‘Support Team’ in please?

Firewalls on or off make no difference, that said the Port Forwarding Rules provide a path through the Firewall for 55002 in each case

  1. Router - DrayTek 2862 -
    DrayTek 2862 - with Port Forward
    Ubiquiti UDM Pro - Downstream of DrayTek providing LAN DHCP 192.168.0.XXX
    Ubiquiti UDM Pro with Port Forward

  2. All the other Ubiquiti Hardware Downstream of UDM Pro

  3. British Telecom Wholesale SoGEA VDSL with Static IP - I live in UK

  4. DrayTek Modem not in Bridge Mode as used for separate LAN required for Work based NAS Backup
    But Port Forwarding on both DrayTek and UDM Pro

Regards Tim

@Tim_Parr, while I don’t have quite as complicated a network as yours, I do have two routers and have configured ARC successfully via port forwarding rules on both routers. Logically your rules are aligned with mine, but where I believe there is an issue is the use of the same subnet for both routers, which may complicate how Roon and ARC work across the LAN and WAN.

I use for my ISP router connecting to my ONT and the WAN, and which serves as the public IP interface, and assigned for all LAN functions including Roon in my second router. My second router also serves as my LAN DHCP server and provides DNS which overrides my ISP DNS for my LAN.

Is it possible to assign the UDM a address where aaa is not a 1, and create a different subnet directly on the UDM rather than use it only for LAN DHCP services?


Thanks for the reply, I suspect you are correct re the Roon ARC not being able to transfer, although logically I do not understand why that is, but I am by no means a Network expert.

However I originally set up the system ‘as is’ rather than reconfigure the DrayTek VPN that is configured to provide an additional work off site backup between the two Synology NAS’s, with reverence to the ‘don’t fix what isn’t broken’ theme.

Whilst I think I understand your suggestion this may take more overall effort/upset than replacing my existing DrayTek 2862 Router/Modem with either a Draytek Vigor160 or Ubiquiti Gateway Modem, and setting up a new/replacement ‘Work Backup VPN’ between the two NAS’s.

Can you shed an light on how the Port Number is generated by the Roon Core/Software please?

Happy New Year when we get there :-)>

Regards Tim

Same issue here. I have setup port forwarding and opened the port in my firewall.

I can confirm its working using a telnet to my external IP (while not on my own internal wifi/network) on port 55000. Also, I can telnet and connect from my local network. I’m quite experienced using firewalls and port forwarding etc, its setup correctly.

cestmoi@internalhost ~/ $ telnet 55000
Connected to roonserver.local.
Escape character is '^]'.
telnet> q
Connection closed.

cestmoi@externalhost ~ $ telnet 7x.1xx.34.58 55000
Trying 7x.1xx.34.58...
Connected to
Escape character is '^]'.
telnet> q
Connection closed.

In my firewall log I can see the external connection:

The pub_source_ip from my firewall log matches my phone’s 5G connection, the pub_dest_ip my external IP from my internet provider.

However, The Roon APP isn’t working. i think the message is the same as from the OP:

"connectivity": {"status":"NetworkTimeout","status_code":998,"error":""},
"external_ip": {"actual_external_ip":"","actual_external_ipv6":"null","router_external_ip":"null"},
"natpmp_autoconfig": {"status":"NotFound"},
"upnp_autoconfig": {"status":"NotFound"}

I have several other port forwards in my firewall and they all work fine.

Maybe there is a way to override the external IP so that Roon doesn’t try to detect it?

Or maybe there is another solution?


Happy New Year (almost, 9 more hours here :stuck_out_tongue: )!

Many thanks for the reply…at least it means I am not as stupid as I thought originally, i.e. missing that ‘tick box’, a good friend who is very experienced also couldn’t see the issue/fix either.

I suspect I will replace DrayTek Router/Modem, with DrayTek Modem and setup a new VPN from work to home for the n+1 Backup…I was sort of hanging on for the Copper VDSL to Fibre switch before changing Router/Modem, that said the Draytek Vigor 166 will do both.

Have a good one, guessing GMT based like me given time stamp to the New Year :-)>

@Tim_Parr, your friend may be able to change the IP address of your UDM to be on the same subnet as your LAN and Roon systems, I am not experienced with the Ubiquiti interface so unfortunately cannot be of much assistance with this.

Regarding the port number ranges Roon chooses for ARC, the first 1023 or so ports are reserved for “standard” network functions. I believe Roon considered how ISPs use and reserve their ports globally and chose a range high enough in the unreserved section to eliminate most potential conflicts with other services. The 55000 range is a good starting point.

And Happy New Year to you also!

Robert and I are volunteer moderators and not Roon employees. We don’t know the inner workings of the code and other than, Roon starts in the 55000 range they have yet to say how they determine which port to use. Its been 55000 for some, 55002 for others, etc.

Personally, I chose a port number that was not in the range that Roon seems to give out and manually setup the port forwarding.

1 Like

Hi @Ernst_Ellensohn.

I don’t think you have the same issue is is mentioned here (take a more detailed look at the error messages).

Please open a new thread and fill in the questions. Otherwise this thread get mixed up.


Kind regards,


Thank you.
Kind regards

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.