Roon Arc was unable to securely access Roon core

Roon Core Machine
iMac with oSX Catalina
Software Roon Version 2.0

Description of Issue

Roon ARC can’t access Roon Core

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“191.aaa.bbb.ccc”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}
}

Hi @Jean_Paul_Garcia.

Could you please answer the below questions;

Who is your internet service provider?

Please list the make and model of your modem and router?

Do you have any additional network hardware, like additional routers or managed switches?

Does your network have any VPNs, proxy servers, or enterprise-grade security?

What machine are you using as a Roon Core, and how is it connected to the internet?

Kind regards,

Maarten.

1 Like

Hey @Jean_Paul_Garcia,

Following up on this thread, can you please fill out the answers to @Maarten_Duits 's questions?

Thank you for your patience while we’ve diligently worked to reach every request for support with port forwarding. The diagnostics you’ve provided suggest that UPnP is not properly configured on your router.

Please first try the following steps:

  • Try to enable UPnP/NATPMP in the web administration interface for the router directly upstream from your Core
  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering
  • Check if your modem is in Bridge mode

If you continue to experience difficulties, please tag the support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?