Roon Arc was unable to securely access your Roon Core

Roon Core Machine

Roon Nucleus+
Roon version 2.0

Networking Gear & Setup Details

Verizon FIOS modem
Linksys WHWO3 v2

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Cannot get ARC to work. Get following message

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“xxxxxxxxx”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“10.44.1.1”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/\” s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/\“>\n<s:Body>\n<s:Fault>\ns:Client\nUPnPError\n\n<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">\n501\nPAL_UPNP_SOAP_E_ACTION_FAILED\n\n\n</s:Fault>\n</s:Body>\n</s:Envelope>\n”}
}

Hi Peter,

Friendly Fellow User. Some things to try.

  1. Turn Upnp OFF and then ON, this sometimes gets things to work. As does a network reboot.
  2. Take a read of the following FAQ: https://help.roonlabs.com/portal/en/kb/articles/arc-port-forwarding#Multiple_NAT for additional suggestions.
1 Like

Hey @Peter_Zorn,

I wanted to check in on this thread to see if you were still running into issues getting arc set up. @Rugby is steering you in the right direction with next steps, can you confirm you’ve set your router to bridge mode, and set up the proper port numbers on both your core and router?

With that,

  1. Who is your internet service provider?
  2. Please list the make and model of your modem and router?
  3. Do you have any additional network hardware, like additional routers or managed switches?
  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?
  5. How is your Roon Core connected to the internet?

Thanks for getting back to me. I access the Internet via Verizon FIOS. I use the Verizon FIOS modem and then connect my Linksys router to that via Ethernet. The Linksys router then forms my home network and WiFi.

Short story, Verizon says I cannot set their modem to bridge unless I get a business account, which is a non-starter. I then turned to the Linksys router. Their tech support showed me how to turn their router to bridge mode. That made Roon ARC work (sort of). My Roon core gave me the thumbs up, and I could use the ARC app fine while I was on my home WiFi. However as soon as I went out and lost my home WiFi connection ARC stopped working. By that I mean could not connect to my Roon core, although there seemed to be some stored music I could play via the app.

So not a great use case. Moreover, setting the Linksys router to bridge screwed up Roon’s access to my NAS. Despite multiple attempts I was unable to successfully get Roon to read the music files stored there (or even connect to the NAS). Also, the very useful Linksys app functionality was lost.

So I gave up. I reverted the bridge setting on the Linksys router. Now I have full access to the app and Roon sees my music storage. What I didn’t get was remote access to Roon. That is a nice to have not need to have.

Thanks again for checking up.

1 Like