Roon Arc was unable to securely access your Roon Core

Roon Core Machine

Roon Nucleus+
Roon version 2.0

Networking Gear & Setup Details

Verizon FIOS modem
Linksys WHWO3 v2

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Cannot get ARC to work. Get following message

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“xxxxxxxxx”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="\” s:encodingStyle="\“>\n<s:Body>\n<s:Fault>\ns:Client\nUPnPError\n\n<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">\n501\nPAL_UPNP_SOAP_E_ACTION_FAILED\n\n\n</s:Fault>\n</s:Body>\n</s:Envelope>\n”}

Hi Peter,

Friendly Fellow User. Some things to try.

  1. Turn Upnp OFF and then ON, this sometimes gets things to work. As does a network reboot.
  2. Take a read of the following FAQ: for additional suggestions.
1 Like

Hey @Peter_Zorn,

I wanted to check in on this thread to see if you were still running into issues getting arc set up. @Rugby is steering you in the right direction with next steps, can you confirm you’ve set your router to bridge mode, and set up the proper port numbers on both your core and router?

With that,

  1. Who is your internet service provider?
  2. Please list the make and model of your modem and router?
  3. Do you have any additional network hardware, like additional routers or managed switches?
  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?
  5. How is your Roon Core connected to the internet?

Thanks for getting back to me. I access the Internet via Verizon FIOS. I use the Verizon FIOS modem and then connect my Linksys router to that via Ethernet. The Linksys router then forms my home network and WiFi.

Short story, Verizon says I cannot set their modem to bridge unless I get a business account, which is a non-starter. I then turned to the Linksys router. Their tech support showed me how to turn their router to bridge mode. That made Roon ARC work (sort of). My Roon core gave me the thumbs up, and I could use the ARC app fine while I was on my home WiFi. However as soon as I went out and lost my home WiFi connection ARC stopped working. By that I mean could not connect to my Roon core, although there seemed to be some stored music I could play via the app.

So not a great use case. Moreover, setting the Linksys router to bridge screwed up Roon’s access to my NAS. Despite multiple attempts I was unable to successfully get Roon to read the music files stored there (or even connect to the NAS). Also, the very useful Linksys app functionality was lost.

So I gave up. I reverted the bridge setting on the Linksys router. Now I have full access to the app and Roon sees my music storage. What I didn’t get was remote access to Roon. That is a nice to have not need to have.

Thanks again for checking up.

1 Like

Hey @Peter_Zorn,

Thank you for letting me know and again my apologies on the delay in follow-up. I’d be curious to see if we could still navigate around the walls your verizon modem has setup.

I have seen other users that could open a port on the Linksys router which points to the Roon core and a port on the VZW router that points to the linksys router. For instance:

Internet → VZW port 12345 → Linksys port 12345 → Roon Core port 12345

While this thread has a different router involved, I’d love to see if it may help you configure port forwarding with your setup : Verizon Fios and Netgear Orbi [Solved - Bridge Mode, Turn Off UPnP on ISP Router]

I’ll be monitoring this thread for your reply :pray:

Not sure how to what you suggest. I get the following screens on my Verizon modem

and this on my Linksys router

Any suggestions how to fill them out?


Hey @Peter_Zorn,

We detailed the information needed here:

With that, here is some of the information to fill out for both Verizon and Linksys router:

IP address: The IP address of your roon core (which you can find in your Roon Settings>General)
LAN/Private/Internal Port: Port 55000
WAN/Public/External Port: This port must be the same as the LAN/Private/Internal port

Didn’t seem to work. I have tried multiple iterations, but here is what I think is correct for the Verizon FIOS modem and Linksys router. Suggestions

Well, one thing I notice is that your Linksys settings use port 5500 and 55000… A mismatch surely?


Good catch, thanks! Unfortunately fixing that did not cause my Roon core to be ready for Roon ARC–get the not ready message below
“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect EHOSTUNREACH, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="\” s:encodingStyle="\“>\n<s:Body>\n<s:Fault>\ns:Client\nUPnPError\n\n<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">\n501\nPAL_UPNP_SOAP_E_ACTION_FAILED\n\n\n</s:Fault>\n</s:Body>\n</s:Envelope>\n”}

Hey @Peter_Zorn,

Thanks for the info. I’d be curious to know what shows when you supply 55000 there.

If it can’t, and you see "Error: I could not see your service on" something from the ISP is blocking the port as this test doesn’t involve forwarding. This site will also reveal what it sees as your public IP. If they don’t match, your ISP may very well be using CGNAT despite them saying you now have a private IP.

Let me know!

There are a number of issue I see with your network set-up which will make this significantly hard to set-up.

I’ll start with your post here:

If your Roon Core is actually behind the Linksys, and everything else is behind your Linksys, then you shouldn’t see more than IP address here. That address will be of the Linksys. If you’re connecting devices to the Fios router and Linksys router then expect issues with devices talking to each other.

The simplest network is 1 router. What are you using the Linksys for and can you get rid of it? Otherwise, plug everything into the Linksys (including Wifi) and only let the Fios router “see” the Linksys router.

Then let’s look at this post

What is the actual IP of Roon Core? You have a typo in the screenshot. Did you correct that?

So let’s look at all the set-up you need to do if you decide to keep 2 routers in your network. First, you’ll hook these routers up in the following way:

Plug Fios router into “the internet” on the WAN (internet) port.
Plug the Linksys WAN (internet) port into a Fios LAN port

Plug everything else into the Linksys LAN ports or the Linksys wireless network. Don’t connect anything else to the Fios router.

You’ll now need to determine the following IP addresses:
Core and Linksys WAN port

You should be able to determine both of those from the Linksys router.

You’ll need to determine the ARC Port Number that Roon Core is using. You can find this in Settings → Roon ARC and look at the port.

On the Fios router set-up a forwarding rule:
TCP protocol, Linksys IP Address of the WAN Port, ARC Port Number
If you need to configure source set to “Any”.

*Do NOT set a forwarding rule to 443 or any other rule that would land at core. That opens up a security hole on a service that isn’t expected to see non-local traffic. Remove any other port forwards unless you know you need them.

On the Linksys Router set-up forwarding rule:
TCP protocol, Core IP Address, ARC Port Number

That should get you going.

1 Like

Thanks for everyone’s help. The good news is that I finally got Roon ARC up and running, and I am loving it. The “solution” was trivial once I thought of it. I simply tried entirely bypassing the Verizon FIOS modem–I took the Ethernet cable going into the Verizon modem and plugged it directly into my Linksys router. Bingo, everything works with no issues.

Again, many thanks for the assistance.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.