Roon ARC will not connect to DECO M5 Mesh

My Roon Core is on a HP PC connected to a mesh network System. It will not connect away from home

I am very much a novice so need help. Thanks

Please complete the support template below, and include details of all your network devices, how your core is connected, and the steps taken thus far.

In addition, please share message from Settings > Roon ARC.

Roon Core Machine

<!-- Include your operating system and machine info (Model, CPU, RAM) -‐>
<!-- Write below this line -‐>

Networking Gear & Setup Details

<!-- Your network gear (model of routers/switches) and if on WiFi/Ethernet, are you using VP -‐>
<!-- Write below this line -‐>

Connected Audio Devices

<!-- Specify what devices you’re using and their connection types, like USB/HDMI/Chromecast, etc.) -‐>
<!-- Write below this line -‐>

Number of Tracks in Library

<!-- Tell us how large your music library is, eg. “30,000 tracks” -‐>
<!-- Write below this line -‐>

Description of Issue

<!-- Tell us about the problem you’re having in as much detail as possible. Screenshots are always appreciated! -‐>
<!-- Write below this line -‐>

Roon Core Machine

HP Pavilion Wave Desktop PC 600-ao55na

Intel Core i5-6400T
Integrated Intel HD Graphic
Integrated Bluetooth 4.2 and Wireless LAN 802.11a/b/g/n/ac featuring Dual-band (2.4 GHz and 5.0 GHz) 1 x 1 technology
128 GB PCIe NVMe M.2 Solid State Drive

Microsoft Windows 10 Home (64-bit)

Networking Gear & Setup Details

Deco M5 Mesh System connected to BT Smart Hub

Wi-Fi 5
IEEE 802.11ac/n/a 5 GHz
IEEE 802.11n/b/g 2.4 GHz
TP-Link Mesh Technology
Optional Ethernet backhaul work together to link Deco units to provide seamless coverage
Access Point Mode
Qualcomm 717 MHz Quad-core CPU
Port Forwarding

Connected Audio Devices

Samsung S9
Naim Unit Atom
Several Sonos Speakers

Number of Tracks in Library
Do not have NAS - Roon connected to Itunes Library plus hard Drive of HP.
Estimated 30000 tracks?

1 Like

It looks like you may have a multiple NAT setup. To confirm this, please share message from Settings > Roon ARC. Edit the external IP to before posting.

As requested:

"connectivity": {"status":"NetworkError","status_code":504,"error":"error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined"},
"external_ip": {"actual_external_ip":"81.159.x.x","router_external_ip":null},
"natpmp_autoconfig": {"status":"NotFound"},
"upnp_autoconfig": {"server_ip":"","found_upnp":true,"error":"Did not find UPnP service with WANIPConnection on network"}

Did you see my last reply?

The message indicates that you have a double layer of NAT in the local network or with your service provider.

Please see the Multiple NAT section in this guide.

Hello Martin.

As far as I can see I have to to change my BT Smart Hub 2 to bridge or modem mode. Is that correct?

However I have trawled the internet and cannot find a method to do this.


Unfortunately, you can’t do this with the BT Smart Hub. Therefore, you need to setup port forwarding in the Smart Hub and the Deco.

Essentially, something like this…

Internet ( → Smart Hub ( → Deco (

…so setup port forwarding in the Smart Hub to (if this is the IP of the Deco) and in the Deco, either use UPnP or port forward to (or whatever is the IP of your core) using port from Settings > Roon ARC.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.