Roon arc won’t connect to mobile network 4g

Roon Core Machine

Networking Gear & Setup Details

Arc won’t connect to mobile network just says poor connection

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Could well be in case you have poor network coverage…or you have a bandwidth limited tarif plan, or you have consumed all your available traffic volume this month, or your subscription is throttled because of excessive utilization of a fair-usage policy…

Check, how much uplink speed and jitter you have in your home and also check the download rates on your mobile device in locations where you face problems.


Question for @danny
Could you make transparent to us, how does the ARC app adapts the downlink at the UE in 3G-, 4G-, and 5G networks (in good and bad network conditions) and how much traffic for an average 44kHz title and the same high-res file will be consumed?
Reason, I’m asking: at the end of the month, some Roon ARC users might start complaining, thar ARC was eating up all their mobile traffic volume;-)

I find it’s always worth restarting the core in case you haven’t tried this.


Hi , I have tried in a 5g area with a good signal.
Every other music app works . So I have gone back to tidal .
Arc plays ok with a WiFi connection. Should I reinstall the app ?


Then, the difference from what I read in your comments is, that direct streaming from Tidal works. Hence, Tidal streams directly to your UE without incorporating ARC at all. It might be, that your uplink at home has a problem.

Again, what uplink and jitter do you measure from home towards the internet?

I am a novice on computer. What should I do ?

Thank you

@Stefan_Mauron - when Roon ARC is streaming a TIDAL or Qobuz track, the streaming is done direct from TIDAL or Qobuz to the smartphone running Roon ARC. The Roon Core is not involved.

1 Like

@Geoff_Coupe That was exactly what I was writing:-)

1 Like

Go here: Port Forwarding Resources - Roon Labs Community

That screenshot from your phone shows that the Roon Core has been unable to automatically configure itself to allow Roon ARC to connect to your Core when it is outside of your home network. Have a read of the ARC Port Forwarding FAQ first to see if you can resolve it. If you can’t, come back here, and we’ll try to help further.

You were talking about uplink speeds…

Yep, because from Roon core point of view, it’s uplink;-)

He has definitely not a mobile network downlink problem

Hi @Peter_Hayes,

If you could complete the template by editing your original post it will help us all with forming a complete picture in order to assist you. Here’s the standard response for 504 errors though. Please let us know. We’ll all receive a notification should you respond!


Thank you for your patience while we’ve diligently worked to reach every request for support with port forwarding. The diagnostics you’ve provided suggest that UPnP is not properly configured on your router.

Please first try the following steps:

  • Try to enable UPnP/NATPMP in the web administration interface for the router directly upstream from your Core
  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering
  • Check if your modem is in Bridge mode

If you continue to experience difficulties, please tag the support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?

I got my issue resolved thanks to this thread. Basically, what I’ve done is;

  1. Went to Settings > Roon Arc to test if Roon arc app can access the core (it said it didn’t have access)
  2. Logged into my home router through browser and managed to find ‘UPnP’ setting turned off. So I turned it on.
  3. Went back to test Roon Arc under settings and it now works on my 4G network! Thank you everyone :smiley:
1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.