Roon ARC works for a couple days and the Stops working

Intel NUC i3

Networking Gear & Setup Details

netgear router ac1450

  1. Who is your internet service provider?

Mediacom Cable
2) Please list the make and model of your modem and router?

  1. Do you have any additional network hardware, like additional routers or managed switches?

  2. Does your network have any VPNs, proxy servers, or enterprise-grade security?

Connected Audio Devices

Samsung Android phone

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

I setup port forwarding because I couldn’t figure out the UPnP setup in my Netgear Router. It will work then all of a sudden it can’t connect. This is so frustrating. I want to buy a lifetime but I need stability.

Does Roon offer support?

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

The only thing stopping me from buying a lifetime sub is I can’t get ARC to consistently work.

Hi @David_Burkholder,

I think you need to create a manual port forwarding rule.

First in the Roon App under Settings → Roon Arc write down the IP address and port number shown there.

Take a look at the manual from page 68.
Follow these instructions.

As name for the custom service you could ie. Roon Arc
As service type select TCP/UDP (Roon only needs TCP, but with some ISP’s this isn’t working).
Enter the port number you wrote down in the fields External Starting Point, External Ending Point
Enter the IP Addres you wrote down in the field Internal IP Address
Hit Apply and check the Roon App if it’s working.

Hope it helps.

Kind regards,


I did this before and it doesn’t work


I don’t know what the port number is which is shown in the Roon Arc app, but i read on this forum that some ISP’s block certain ports. Could you change the port number in the Roon Arc app to ie. 44135 and try to create a manual port forwarding to that port number?

Kind regards,


Thanks for the help. It will work for a day and then the next day it gives me the error it can’t connect to my Roon core. How could it work randomly? Wouldn’t the port either be set up to work or not work. This is so frustrating especially after I dropped $700 for a lifetime.

One possible cause is simply an issue in ARC. Many people have had success with connection errors after resetting the ARC app in settings.

Another possibility is the ISP or the mobile provider. My ARC worked and then one day it did not work from my provider’s cell network. (It did work from other networks). A port scan from the phone revealed that the port was closed. Next day it worked again. Weird things can happen in networks.

Install a network scanner app on your phone and remember your external IP address and the port number you are using. When it does not work the next time, scan the IP and port from the phone (while it is in the cell network). The port should show as open, see if it reports as closed or blocked.

1 Like

Hey @David_Burkholder,

It’s great to see you on the Roon Community! You have my sincerest apologies for the delayed response here, we’ve been dealing with a higher-than-usual volume following our release and we’re working as quickly as we can to get back to everyone.

@Suedkiez makes a great point with the network scanner. Let me know the results of findings there!

Outside of that, I’m seeing general timeout errors which could be related to either wifi or your cellular network. When do these drops in connection typically occur, while you’re at home or out on the go?

We’re also seeing low memory errors prior to the timeouts. How big is your library, and what file resolutions are you typically adding to your Arc library?

Please provide the model type and specs of the device running arc :pray:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.