Roon ARC works for a couple days and the Stops working

Intel NUC i3

Networking Gear & Setup Details

netgear router ac1450

  1. Who is your internet service provider?

Mediacom Cable
2) Please list the make and model of your modem and router?

  1. Do you have any additional network hardware, like additional routers or managed switches?

  2. Does your network have any VPNs, proxy servers, or enterprise-grade security?

Connected Audio Devices

Samsung Android phone

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

I setup port forwarding because I couldn’t figure out the UPnP setup in my Netgear Router. It will work then all of a sudden it can’t connect. This is so frustrating. I want to buy a lifetime but I need stability.

Does Roon offer support?

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“150.aaa.bbb.ccc”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}
}

The only thing stopping me from buying a lifetime sub is I can’t get ARC to consistently work.

Hi @David_Burkholder,

I think you need to create a manual port forwarding rule.

First in the Roon App under Settings → Roon Arc write down the IP address and port number shown there.

Take a look at the manual from page 68.
Follow these instructions.

As name for the custom service you could ie. Roon Arc
As service type select TCP/UDP (Roon only needs TCP, but with some ISP’s this isn’t working).
Enter the port number you wrote down in the fields External Starting Point, External Ending Point
Enter the IP Addres you wrote down in the field Internal IP Address
Hit Apply and check the Roon App if it’s working.

Hope it helps.

Kind regards,

Maarten.

I did this before and it doesn’t work

@David_Burkholder,

I don’t know what the port number is which is shown in the Roon Arc app, but i read on this forum that some ISP’s block certain ports. Could you change the port number in the Roon Arc app to ie. 44135 and try to create a manual port forwarding to that port number?

Kind regards,

Maarten.