Roon Bridge Docker Coreelec

Hi,
I installed Roon Bridge in Docker on my CoreElec device. In Portainer, I can see it’s there, running, no errors. But I can’t see the Roon Bridge in Roon Audio settings? Any idea what could be wrong?
Thank you

I have no idea about Portainer or CoreElec. But Docker usually has a private subnet for the containers. This must be set to host instead of bridged, so that the Bridge and the Core are on the same subnet.

I have Roon Server running in Docker on my Synology NAS and it’s working perfectly.

In the living room I have the CoreElec device where I installed Roon Bridge in Docker.
As “host”, definitely not bridged. So I don’t see any reason why it’s not visible to Core.

Both Docker-Containers need to have network configured as Host. But I believe you did this on the NAS, too. As you say it’s working.

Do you have CoreElec and the NAS on the same Network (same subnet)? Can you see the CoreElec machine from the NAS. Any firewalls running on any machine?

Hi, yes, both as host.
Yes, both same network, using cables only.
KODI in CoreElec device can see and play files on NAS.
Yes, firewall is active on my NAS, but only for outsiders. Everything on local network is allowed in firewall.
Maybe this might help, see the log from RoonBridge container:

00:00:00.015 Warn: get lock file path: /tmp/.rnbgem0-
00:00:00.367 Trace: [childprocess] using unix child process
Initializing
00:00:00.557 Info: Starting /boot/bin/RoonBridge/Bridge/RoonBridgeHelper
00:00:00.594 Info: ConnectOrStartAndWaitForExit RAATServer, path: /boot/bin/RoonBridge/Bridge/RAATServer
Not Running (.o)
00:00:00.034 Warn: get lock file path: /tmp/.rnbhgem0-
Running

What about the other way around? Does CoreElec has a Firewall? Are you running the roon bridge docker with privileged rights? - Might be possible, that the docker user has no access to the Audio-Devices.

Sorry, also just digging around, because I have no clue… :wink:

No firewall there… It’s very plain system without any special features.

I tried something… I removed Docker and started again. The way it works here is that everything is installed through KODI environment. There’s about 30 containers to choose from and all from “LinuxServer.io’s”.
So I just installed NetData and Portainer. One change is there in network. Both, Netdata and Portainer are using “lsio” instead of bridge or host. So when I was installing RoonBridge now, I modified the command to:
docker run --name RoonBridge --net=lsio -e TZ=Europe/Dublin -d -v /storage/.config/docker/roon:/var/roon dubodubonduponey/roon-bridge:latest

It installed and container is running. Also got similar address as other containers, starting 172.18.0…
Which wasn’t the case before. I thought I finally done it, but then I checked the log and it’s same as above:
00:00:00.017 Warn: get lock file path: /tmp/.rnbgem2000-
00:00:00.386 Trace: [childprocess] using unix child process
Initializing
00:00:00.577 Info: Starting /boot/bin/RoonBridge/Bridge/RoonBridgeHelper
00:00:00.614 Info: ConnectOrStartAndWaitForExit RAATServer, path: /boot/bin/RoonBridge/Bridge/RAATServer
Not Running (.o)
Running
00:00:00.032 Warn: get lock file path: /tmp/.rnbhgem2000-

The bridge container should not have a separate IP. So the lsio is a virtual network from docker. Did you tried starting the docker image manually as stated in the readme to the docker image: GitHub - dubo-dubon-duponey/docker-roon: Roon server & Roon bridge containers for amd64, arm64, arm/v7 (based on debian:buster-slim)

Sorry, I can’t see it… What exactly are you talking about?

Change the docker command to

docker run -d --net host -e TZ=Europe/Dublin --name RoonBridge --read-only --cap-drop ALL --group-add audio --device /dev/snd -v /storage/.config/docker/roon:/var/roon dubo-dubon-duponey/roon-bridge

Still no luck…

00:00:00.018 Warn: get lock file path: /tmp/.rnbgem2000-

00:00:00.392 Trace: [childprocess] using unix child process

 Initializing

00:00:00.574 Info: Starting /boot/bin/RoonBridge/Bridge/RoonBridgeHelper

00:00:00.606 Info: ConnectOrStartAndWaitForExit RAATServer, path: /boot/bin/RoonBridge/Bridge/RAATServer

Not Running (.o)

00:00:00.031 Warn: get lock file path: /tmp/.rnbhgem2000-

Running

Docker stopped working altogether… Even Portainer and Netdata don’t work anymore. When typing command Docker ps, it’s empty… I think I installed and removed that RoonBridge so many times, that it just got tired of me… I don’t have the strength to reinstall the CoreElec so I’m giving up on this and I ordered 2012 Mac mini from eBay to run the RoonBridge.