Roon Bridge for ARM: a beginner’s guide to Raspberry Pi and Cubox-i

I fully agree. Please, @Gordon_Garrity, can you fix that. Make it auto-updating. I think Roon Ready endpoints deserve that.

All, thanks for the ideas. We are already working on an Alu case with OLED display and rotary encoder etc.

I take note about the auto updates too.

Moving offices this week so will need a little time.


The Pi and Cubox are amongst the most widely used boards, are well-supported and have (especially in the Pi’s case) a wide ecosystem (HATs, cases, etc.). Other than that – there’s no reason why a BeagleBoard (or a WandBoard, or any of the other ARM boards Iinked to) wouldn’t make a fine Roon Bridge. Same with OS distros: if you’d like to run Arch, it’ll be fine (or even better). I just would not recommend it to beginners.

Thanks, any security concerns with these OS’ end users should worry about?

Also, would love to see a beginner’s guide from you on Linux distros for RoonServer. I like the way you’ve laid this out.

Thank you Rene, a wonderful resource.

I think his guide is knowledge base quality. If I would be Roon (@andybob) I would move it out of the community section into the official user guides spot of Roon.

We are already working on an Alu case with OLED display and rotary encoder etc.

Will this case with all the above compatible with all the Pi and IQAudio combo’s already in the field/world, @Gordon_Garrity? Any estimation of time (month in 2016)?

And a rotary encoder, with leds (eg. this rotary encoder with led ring)? Cool!

Please make the case look awesome high-end for an affordable price. Your product deserves it (and Roon too :wink: eg. like this or like this)

I like this nice base with no screws on the front panel

Thanks, any security concerns with these OS’ end users should worry about

You need some good understanding of and skills in Linux to go the road of the self-deployed-OS way to keep them updated and secure. The latter requires the most skills and knowledge.

If you stick with IQAudio, it will work out if the box (when you copy their image to the sd of the Pi). Depending on their updating and hardening skills it will be ‘ok’, ‘good’ or ‘awesome’.

It’s more or less choosing between a diy way and an easy way. Up to you.

In general the biggest issue in the world of the Internet-of-things (where these endpoints are close to in my view) will be keeping them secure. You just need 1 vulnerability in your network to compromise the network. And with more and more things connected to networks and in the end to the internet, more and more possibilities for vulnerabilities.

Read: what-should-be-done-to-secure-raspberry-pi
Or: make-your-raspberry-pi-more-secure

Besides, Roon also need some improvements as currently it runs as root (at least on Linux using the install), which is the last you want to do on a system. It goes against the basic security guidelines/best practices.

1 Like

OK, well that’s it. I’ve ordered an RP3 today. Thanks Rene - awesome job. Will let you know how I get on !

1 Like

for me it does not work. I’m using an older raspberry pi B with armv6. As you mentioned older pi’s will work as well, but in my case not.
I tried both: the easy install script and the manual install method.
Does anyone can help?

The install script always fails because of the wrong architecture. It says this script is for armv7 and wont work on your hardware. I tried to change the line with “ARCH=armv7hf” to something like armv6, armv6l or armv6hf, nothing worked.
uname -a tells me that I have an *armv6l
I also tried the manual method:
Downloaded the package and copied it to /opt/RoonBridge

root@minibian:/opt/RoonBridge# ./

Checking to see if RoonBridge can run on this machine
Checking for Binary Compatibility [ OK ]
Checking for ALSA Libraries [ OK ]


root@minibian:/opt/RoonBridge# ./
./ line 44: 8866 Illegal instruction $ROOTDIR/Bridge/RoonBridge “$@”
./ line 34: kill: (8866) - No such process

I really hope someone can hep me.

Thanks in advance!

Uh-oh… That’s a small oversight in the instructions. Roon Bridge is compiled for ARMv7 (and x86) only – older Pi’s with earlier chipsets are not supported. I’ve corrected the post above – sorry for any confusion here!

OK, thanks for clarifying this.

I’m going to ask a really dumb question - in the installer script is that -0 (zero) or -O (letter “O”)
I can’t seem to get the script to download the file but i am very new to this. RP3 with raspbian jessie lite installed

so frustrating - i run the first command of the installer script and lots of stuff happens but the screen appears to say “package uninstalled” and the file is not found. Don’t understand what i am doing wrong ?

what am i doing wrong ?

The installer seems to do its thing but when I try to execute it there is no such file or directory. Any Linux rooners help would be appreciated

Hi Paul,

The curl command isn’t finding and downloading the Roon Bridge installer, so the subsequent commands don’t have anything to operate on.

The curl option -0 (zero) forces curl to use http1.0 rather than http1.1. I can’t see any reason to do that.

The curl option -O (capital oh) writes the output to a local file of the same name and is, I think, the intended option. It looks like a capital Oh on the KB page but may be written as a zero in Rene’s guide above.

Try the series of three commands listed in Rene’s section “Installing Roon Bridge” again, but use -O instead of -0 as the curl command option.

Check back how it goes. You’re very nearly there !

Thanks Andy - out of the house right now but will try when I get back and report progress

Thank you Rene.

Great resource for a Linux noob like me.

Re: Cubox-i instructions to follow – please stay tuned

Looking forward to the CuBox version. I purchased one but l’m not able to get it working from my Mac. Hoping to get it up an working with your step by step instructions à la Raspberry Pi.

Thanks in advance.


Hi Markus,

I’ve been down with the flu for a few days – sorry for the delay.

The most important is to run the Legacy version of Armbian as preferred OS. The latest version (Jessie Server; 5.07 with kernel 3.14.65) that is currently offered for download has full support for all bitrates on S/PSIF. Other/older releases have troubles at 88.2/176.4kHz.

As Armbian is distributed as a RAW file, writing to SD card is slightly different.

I double checked – it is O (as opposed to zero) in the instructions as well as in the knowledge base.

In case curl gives you a hard time, you can do ‘wget https://etc…’ as well. I usually do. I’m lazy. :wink:


Oh I could kiss you all !! All up and running and sounding fantastic. Thank you so much for your help - you guys rock !! Now let the music begin :+1::+1::+1::+1::+1::+1:


Hi Rene

Thanks for the hint. I tried again with Armbian (Legacy – Jessie Server) and… it just worked! Love it!

Tried before with (vanilla) and failed.

Thanks again