Roon bridge on raspberry pi

Hi Folks,

I’m really new to roon and really surprised of what does this software makes out of my music library.

My setup is as follows:
dedicated headless music server with fedora 23 (vortexbox with squeezebox services disabled) used with roon server core as music server and output for living room.

This works quite well with just a few network lacks. Iḿ not sure why this happens. Often there seems to be an network issue and the connection is lost. Sometimes I have to relog in to my roon Account again. But the network itself is stable. My Controls have no issues due to the fact that they are able to browse internet and so on. The server is online as well (I had an active ssh session while these phenomens happens)

The second thing is that I cannot install the bridge on my raspberry pi. As described [here] (Roon Bridge for ARM: a beginner’s guide to Raspberry Pi and Cubox-i) it should also work with the older raspberry pi’s.

I tried both: the easy install script and the manual method:

The install script always fails because of the wrong architecture. It says this script is for armv7 and wont work on your hardware. I tried to change the line with “ARCH=armv7hf” to something like armv6, armv6l or armv6hf, nothing worked.
uname -a tells me that I have an *armv6l
I also tried the manual method:
Downloaded the package and copied it to /opt/RoonBridge

root@minibian:/opt/RoonBridge# ./

Checking to see if RoonBridge can run on this machine
Checking for Binary Compatibility [ OK ]
Checking for ALSA Libraries [ OK ]


root@minibian:/opt/RoonBridge# ./
./ line 44: 8866 Illegal instruction $ROOTDIR/Bridge/RoonBridge “$@”
./ line 34: kill: (8866) - No such process

I really hope someone can hep me.

Thanks in advance!

The official download link is talking about “ARMv7”. So I don’t see a chance to make it work.
The file is a bash script that will launch RoonBridge. As the binary cannot be launched the script can’t find the process id (8866) and returns the error message (illegal instruction).
Unfortunately it is not as easy as changing the architecture in the start script.

I’ve answered your question in the other thread as well, but for the sake of clarity: Roon Bridge is compiled for ARM7 – older PI’s will not be able to run Roon Bridge, as they lack the required chipset. While in theory I think Roon Bridge could be compiled for other chipsets – I doubt that we’ll see this anytime soon.

For now, you’re probably best off running PiCorePlayer on your Pi and use Roon’s support for the Squeezebox protocol for audio distribution.

OK, thanks. With piCorePlayer it works, even if I cannot group my zones together due to the different protocols. But OK, thats a workaround aslong as I have no armv7 raspi.

Thanks for your answers and the help.