Roon Bridge for ARM: a beginner’s guide to Raspberry Pi and Cubox-i

OK, thanks for clarifying this.

I’m going to ask a really dumb question - in the installer script is that -0 (zero) or -O (letter “O”)
I can’t seem to get the script to download the file but i am very new to this. RP3 with raspbian jessie lite installed

so frustrating - i run the first command of the installer script and lots of stuff happens but the screen appears to say “package uninstalled” and the file is not found. Don’t understand what i am doing wrong ?

what am i doing wrong ?

The installer seems to do its thing but when I try to execute it there is no such file or directory. Any Linux rooners help would be appreciated

Hi Paul,

The curl command isn’t finding and downloading the Roon Bridge installer, so the subsequent commands don’t have anything to operate on.

The curl option -0 (zero) forces curl to use http1.0 rather than http1.1. I can’t see any reason to do that.

The curl option -O (capital oh) writes the output to a local file of the same name and is, I think, the intended option. It looks like a capital Oh on the KB page but may be written as a zero in Rene’s guide above.

Try the series of three commands listed in Rene’s section “Installing Roon Bridge” again, but use -O instead of -0 as the curl command option.

Check back how it goes. You’re very nearly there !

Thanks Andy - out of the house right now but will try when I get back and report progress

Thank you Rene.

Great resource for a Linux noob like me.

Re: Cubox-i instructions to follow – please stay tuned

Looking forward to the CuBox version. I purchased one but l’m not able to get it working from my Mac. Hoping to get it up an working with your step by step instructions à la Raspberry Pi.

Thanks in advance.


Hi Markus,

I’ve been down with the flu for a few days – sorry for the delay.

The most important is to run the Legacy version of Armbian as preferred OS. The latest version (Jessie Server; 5.07 with kernel 3.14.65) that is currently offered for download has full support for all bitrates on S/PSIF. Other/older releases have troubles at 88.2/176.4kHz.

As Armbian is distributed as a RAW file, writing to SD card is slightly different.

I double checked – it is O (as opposed to zero) in the instructions as well as in the knowledge base.

In case curl gives you a hard time, you can do ‘wget https://etc…’ as well. I usually do. I’m lazy. :wink:


Oh I could kiss you all !! All up and running and sounding fantastic. Thank you so much for your help - you guys rock !! Now let the music begin :+1::+1::+1::+1::+1::+1:


Hi Rene

Thanks for the hint. I tried again with Armbian (Legacy – Jessie Server) and… it just worked! Love it!

Tried before with (vanilla) and failed.

Thanks again


Well though I have zero linux experience I thought these instructions were clear enough so I’d give it a go as I really want to replace all my airport expresses so all my zones can use RAAT and be able to play together with my other Roon RAAT zones.

I bought two HiFiBerrys one with the Digi+ board for connecting to the home theater receiver via coax and one with the DAC+ board for use with active speakers in the kitchen.

Building them was easier than I thought, though the HiFiBerry acrylic cases are very cheap looking and definitely to be hidden :slight_smile: I followed the instructions carefully, downloading all the programs was pretty tedious and took a while but not too difficult. Burnt the card connected to the Pi, updated everything etc. Installed Roonbridge. Great, nearly there. Check Roon is seeing the device, yes great nearly there…

But I need WiFi for these two rooms (unfortunately there is no other way.) Set up the Wifi on the Pi as instructed but Roon won’t see the device and neither will Fing find it unless they are connected to the router via ethernet cable. Argggh.

Try the second device, everything goes much quicker of course, but the same problem there as well. Arggggggggggggh

I did check the suggestion to run ifconfig see if there is anything in inet addr and there is. Here is what I get However all my other devices are on 192.168.1.X so something does not seem right with the WiFi setup.

So what do I now? Please bear in mind I have no linux skills and so I can only follow setup by step instructions.

Many thanks

When I setup my wifi on the pi I use the wpa_passphrase command:

You can test the output by entering

pi@raspberrypi:~ $ wpa_passphrase "Your-Wifi-Name" "Password"
pi@raspberrypi:~ $

You can also directly output this into a file (e.g. ~/my_wifi.conf). The “~” indicates your home folder.

 pi@raspberrypi:~ $ wpa_passphrase "Your-Wifi-Name" "Password" > ~/my_wifi.conf

Then just replace the wifi config with this new file by:

pi@raspberrypi:~ $ sudo cp ~/my_wifi.conf /etc/wpa_supplicant/wpa_supplicant.conf

Restart your network device (or reboot the pi):

pi@raspberrypi:~ $ sudo ifdown wlan0
pi@raspberrypi:~ $ sudo ifup wlan0
1 Like

Thank you this worked! Both devices are now showing up in Roon via WiFi. Too late to test the sound and syncing of zones now but feels like I’m there now.

Got them both working fine this evening. Sounds great and the zones work together great.

Thank you Rene for your instructions and Christopher for your help resolving the wifi problem. Much appreciated.


:rage: thanks for that Rene. Now i had to order another pi to upgrade my diy streamer/dac from pi1 to pi3 to take advantage of the roon bridge. Will also need to dig out the new i2s pin layout on the header (at least don’t need to solder in a p5) so i can connect my dddac over i2s again.

Thanks @RBM for that piece of proza. Worked like a charm.

I did hook it up over i2s to my DDDAC, so was tinkering a little with the settings.
If you dont’t see a roon bridge listed in Roon, but when you go to settings/about section and you do see the bridge there (with version, etc) then it simply does not have a valid audio output on the bridge.

1 Like

Finally found a little time for an update – the Cubox is now included in the instructions for your viewing pleasure.


Thx for the excellent guide @RBM
Just got my first RPi today and have it playing music as a Roon Transport right now! All thanks to the very good guide!

1 Like