Roon Bridge for ARM: a beginner’s guide to Raspberry Pi and Cubox-i

Pi-DAC+ back on stock :slight_smile:

Thank you, kind sir.

Ordered one + case. Just for fun.

1 Like

Archphile install.
Mostly the same as above, but:

  1. pacman -Syu which
  2. y
  3. wget (instead of apt-get -O …).

Working nicely with my RPI2 (amanero USB - I2S) and Cubox-I (amanero USB).

Edit: altered the code as crieke suggested :slight_smile:

I would also mention that the archlinux also has upnp / airplay installed but not activated. If you want them active its easy to do so. Its also fairly easy to set up in general with good guides in the section.

Hi Gunnar,
as an addition to your post, I’d recommend to use

pacman -Syu which

the wiki of archlinux advises against “-Sy” as it could lead to dependency issues (probably not for this specific package…).

1 Like

Hi crieke - hoping you can help me troubleshoot my inability to connect via WiFi. I have my Raspberry Pi 3 running Roon Bridge using the instructions on this page and everything works well when connected to a network cable. After following both RBM’s wifi instructions and your instructions, I came up short. IPScanner does not recognize my Raspberry when on wifi and neither does Roon.

Here are screen shots of my config. Spot any errors?

And here’s what I get when I check the wlan config:

Thanks for you help! Aloha, -Mark

You will need to put the values for ssid and psk (if in use) between “”:


The 4th line (directly above ‘network={’ should not be in the conf file – please delete it entirely.

Well I’ve managed to purchase a hifiberry and last night a Pi 2 arrived so expect a rediculous amount of quite simplistic if not downright silly questions- thanks in advance!


1 Like

Brilliant post RBM, I’ve just followed each and every step to set-up my raspberry PI 3 and it worked Ike a charm.
Current set-up:
Ron Core running on Mac mini
DAC Chord Hugo USB attached to Raspberry PI3 as roon end point.


Hey - I asked every dumb question possible and these guys helped me through. I have now had many hours of reliable sonic bliss. You are in good hands…


Okay first query, I’m downloading all the relevant programs to have them ready and firefox warns of an invalid certificate for the puTTy download link, adding an exception here brought avast into action

any thoughts?


Many open source tools get hijacked. Not sure if this is the case with the message you get atm. But the “check your sources” tip is allways a good starting point.

This was trying to download the exe file, I have successfully downloaded the msi file and installed Putty with no objection from avast.

and I’m still in Windows!, wait until I get to Linux!

Well, well, well these must be excellent, fool proof instructions, many thanks Rene.

Had some worrisome moments when I had no sound but it turned out to be an optical cable issue.



Oh that little purple dot - makes it all worthwhile…

These instructions were incredibly easy to follow! I’ve got roon installed and successfully outputting to my USB DAC without issue. One big problem though. Enabling Wi-fi has been impossible for me.

This is with a new Raspberry Pi just bought today and downloading the OS from the links in the first post. I haven’t done any modifications or suggestions from the web. I’ve also tried to reload the OS 3 times and get stuck at the same point. I see wlan0 but it doesn’t get an IP.

pi@raspberrypi:~ $ ifconfig wlan0
wlan0 Link encap:Ethernet HWaddr b8:27:eb:9f:1a:97
RX packets:9 errors:0 dropped:9 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1140 (1.1 KiB) TX bytes:0 (0.0 B)

pi@raspberrypi:~ $ sudo ifup wlan0
wpa_supplicant: /sbin/wpa_supplicant daemon failed to start
run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
Failed to bring up wlan0.

Anyone have any ideas?

I too had problem getting wifi to work. Did you see this post from Christopher above? This worked for me. Sorry I can’t seem to post a link to that part of the thread so its all copied below again.

When I setup my wifi on the pi I use the wpa_passphrase command:

You can test the output by entering

pi@raspberrypi:~ $ wpa_passphrase “Your-Wifi-Name” “Password”
pi@raspberrypi:~ $
You can also directly output this into a file (e.g. ~/my_wifi.conf). The “~” indicates your home folder.

pi@raspberrypi:~ $ wpa_passphrase “Your-Wifi-Name” “Password” > ~/my_wifi.conf
Then just replace the wifi config with this new file by:

pi@raspberrypi:~ $ sudo cp ~/my_wifi.conf /etc/wpa_supplicant/wpa_supplicant.conf
Restart your network device (or reboot the pi):

pi@raspberrypi:~ $ sudo ifdown wlan0
pi@raspberrypi:~ $ sudo ifup wlan0

Worked perfect! Thanks!

Fantastic writeup! Got it to work on my first try. Thanks a bunch.

edit - My pi 3 is now not showing up as a device. This first happened when I tried to switch from ethernet to wifi. I wasn’t haven’t any luck with wifi so i went back to ethernet but now Roon won’t see the pi even hardwired. My Pi is connected to an external DAC. Any thoughts? I’ve tried rebooting the pi, the computer, Roon and even reinstalled the Pi software without any luck. Roon and the pi ran 9 straight hours today without a hiccup until I tried wifi.

Can you still log in to your Pi? If so – you can issue

sudo systemctl status roonbridge.service

to see whether Roon Bridge is running OK.

For now, you may also want to undo the changes you made to wpa_supplicant.conf and reboot the Pi afterwards.

If Roon Bridge is OK, you can issue

aplay -l

to check whether your DAC is still seen by Alsa. If your DAC is not seen (for whatever reason) or is turned off, the Pi-zone won’t be visible in Roon.