Roon Bridge on DietPI: impossible to update from build 164 to 167 [Resolved by Dan_Knight (DietPi Creator)]

(Craig Reilly) #22

Manual install works. See other thread on same topic, may bad for opening a second thread.

(Gerald Richardson) #23

I was also able to update my three DietPi devices with these commands. Thanks.

(John Aiello) #24

I am not doing the commands…I think. I prefer to wait for this to get fixed.

(Jeffrey Robbins) #25

I am still getting into DietPi as root user and got the same error messages. I manually updated all seven of my rpi3s (all on updated DietPi) with compete success. I had to re-enable each device in Roon, however. Automatic certainly would be better.

Copying in @dan_knight, the founder of DietPi, to comment here. JCR

(Lukas Luis) #26

Is there a sonic improvement with the new Roon Endpoint update? I ask because I don’t bother to install updates unless my system sounds better after.

1 Like
(Tony) #27

I don’t recall Roon ever commenting on ‘sonic improvements’ with updates, so presumably you are stuck on a very old version of Roon?

#28

Apologies, but I have no idea where I’m supposed to post an error… I ran the Roon Update just now, and I get this error from my Pi’s:

The error for 1.0 build 64 is “There was an error checking for an update”

Please let me know if you have fixed this or how to proceed.

What's up Roon? I posted about an error
(Henry) #29

You are not alone but until this is fixed Roon have confirmed you are fine to continue to use older Bridge builds.

1 Like
#30

Thanks for letting me know they are aware of the error. They need an email list to let their subscribers know when there’s an error, and an eta. Having to post on a BBS is pretty old school.

I guess they need better programmers? :stuck_out_tongue:

What's up Roon? I posted about an error
(Mr Fix It ) #31

I’ll have to check mine when I get home but pretty sure all my rpi endpoints updated no issue. I have mostly ropieee but also 2 Allo sparky with dietpi builds on 6.17 iirc

(Lukas Luis) #32

I am an old school Mainframer and I don’t fix things if ain’t broken but the latest update of Roon Server broke my setup and could no longer play DSD (DAC not locking on to the signal). I needed to update the Roon Bridge to get it going again.

It’s quite a bit of work as the Bridge is on another network segment.

1 Like
(Mr Fix It ) #33

Roon Bridge should update automatically tho there is an issue for dietpi builds that will be resolved in 6.18 release for the failed 164 to 167 update

(Tony) #34

My dietPis are all on much older builds (it ain’t broke…) 157-159 from memory. Is it safe to update to the latest Roon release?

(Before anyone asks, updating DietPi from 15X to 16X involves a complete reflash and setup of the SD card and with 5 endpoints in the system it is not something I have found time or inclination for since V6 was released. I should have plenty of time at the end of December, so no excuses then!)

(Mr Fix It ) #35

the command in the linked thread should work

(David Snyder) #37

If you’re not comfortable with running the commands, I found that simply uninstalling the two Roon packages and then re-installing them did the trick.

DietPi will reboot after you remove Roon Extension Manager and Roon Bridge…


One more reboot, and you should see your zone show back up in Zoon with version 1.67 installed.

(Nicolas Will) #38

Single command line to reinstall Bridge from the command line:

dietpi-software reinstall 121

2 Likes
(David Snyder) #39

I guess I would do 86 as well…just to be safe.

(Geoff Coupe) #41

The cause of the issue has been found…

1 Like
(Gerald Sullivan) #42

Thanks. Your curl -O worked. The first replier had curl -0 which doesn’t work.

Gerald

(B Frank) #43

Hi.
Manual install via SSH worked on mine (DietPI latest build + HifiBerry DIGI PRO) too

Have fun
Bernie