Roon Bridge on DietPI: impossible to update from build 164 to 167 [Resolved by Dan_Knight (DietPi Creator)]

(Rémi) #1

@support following today’s rollout of Roon 1.5 (Build 360), the update of Roon Bridge didn’t succeed. After seeing the downloading progress bar and “Installing 1.0 (build 167) stable” message i get the following error message “There was an error checking for an update”.


Never had this before.
Issue remains after rebooting Core and Endpoints (both under the latest DietPi).

1 Like
Roon Bridge Update on Dietpi
Roon Bridge version
Roon Build 360 error
My only solution?
Still no fix for Roon Bridge update?
Roon Bridge Release Notes
(Noris) #3

Hello @alec_eiffel,

Thanks for contacting support, I’d be happy to assist here. Can you please try rebooting your Roon Bridge and then try to perform the update again? You may want to also reboot your networking gear. Please let me know if this helps.

Thanks,
Noris

(Rémi) #4

Nope didn’t help, thanks for jumping on the issue.
By the way the Roon 1.5 build 360 software release note say " *Build xxx of Roon Bridge is also live for all platforms." without referring to build 167. Also the list of bugs fixed doesn’t really seem to be related to endpoints, so maybe there is no need to update Roon Bridge?

(Rémi) #5

NB: I tried to uninstall Roon Bridge and reinstall with dietpi-software utility. It reinstalled build 164 (the one I had before) and not the supposedly latest build 167.

(John Aiello) #6

Mine worked on the device I have that is running ropieee but not on the one running dietpi. That one reports that there was an error checking for the update even though it downloads it.

(Mike) #7

I just edited that, sorry about that.

We’re looking into what’s going on here, but all the changes are in Roon, not Roon Bridge, so I wouldn’t worry about this too much.

2 Likes
(Dick Vliek) #8

Same here:

I do get a progress bar that the update is downloading but it always ends in above error.
Dietpi is up to date (6.17.12)

#9

Yep, same problem on Digione for me. “There was an error checking for an update”

(John Aiello) #10

It’s all dietpi.

(Jim) #11

Agreed. My Ropieee device updated RoonBridge normally, but DietPi 6.17.12 failed to update RoonBridge not on a different RPi with identical behavior as the OP.

Paging @Dan_Knight

1 Like
(Magnus) #12

Same error here, downloads and looks like it installs, then error. I updated to latest dietpi and reboot but still error.

(Geoff Coupe) #13

Interesting - my Ropieee device tried installing, and then gave the “There was an error checking for an update” message. Tried it again, with the same result. However, the device is just a display device, not an audio endpoint, so I’m not too bothered at the moment.

(Mike Ormerod) #14

Same issue for me with Dietpi on my Allo USBridge.

1 Like
(David Bertagni) #15

Same issue here. DietPi v6.17.12 across 5 RPi 3 Model B (armv7l) systems with a DragonFly and various allo hats.

(David Bertagni) #16

All running Roon Bridge v1.0 build 164

#17

The update failed on my DietPi too so I just installed the update from the command line and it appears fine now.

curl -O http://download.roonlabs.com/builds/roonbridge-installer-linuxarmv7hf.sh
chmod +x roonbridge-installer-linuxarmv7hf.sh
sudo ./roonbridge-installer-linuxarmv7hf.sh
1 Like
(Jim) #18

Interesting. I’ll have to check, but I seem to recall from recent release notes that DietPi transitioned a few releases ago from running everything as root to assigning the various programs as their own non-root users. Maybe that is related, since when you login to do it on the command line, you are (typically) root.

RoonBridge was updated to build 164 on July 5, so any DietPi release since 6.12 (also in July) could have quietly broken the RoonBridge update functionality until the 167 release a few days ago.

(Magnus) #19

That worked fine for me, cheers!

1 Like
(Craig Reilly) #20

My dietpi installation on a RPI3B+ is not able to update to the latest build 167. From the Roon on my PC I can see the PC and my NAS have updated to version 1.5 build 360. The bridge currently is on build 164 ans downloads build 167 but then throws an error.

v6.17.12 | RPi 3 Model B+ (armv7l)

Given that it shows build 164 and re-downloads build 167 every time I look at the “About” page, I am assuming the build is not getting installed. I have rebooted the RPI box and I have uninstalled and reinstalled the roon bridge software on the RPI box. Any suggestions?

1 Like
(Boris Dyukin) #21

The same issue.