Roon Bridge on Linux disables audio

I just installed roon bridge on linux. However, when I play any sound on my machine, roon cannot detect my DAC. And similarly, when I’m playing sound through roon, no other applications can output any sound.

I would like to keep using my pc but stream roon in the background. Am I doing anything wrong or is this just not supported on linux?

Some details:
Audio server: ALSA (no pulse or jack installed)
Linux distro: Arch (also tested on ubuntu with the same problem)
DAC: Focusrite Scarlet 2i4 gen 2
Roonbridge version: 1.0-3 (https://aur.archlinux.org/packages/roonbridge/)

From Exclusive Mode I understand that this is normal behaviour.

True, maybe I should have clarified. In my device setup, there is no option to enable/disable exclusive mode.

Oh, I see what you mean now. Linux is forced into exclusive mode. That’s a real shame.

Roon presents options based on what is/ is not available for that audio device. For example, ASIO only works in exclusive mode, so the Exclusive option will not be displayed.

What is the output device you are using?

I’m using a USB audio interface (Scarlet 2i4). It is detected as an ALSA device in Roon. But as @Harald_Pott mentioned, ALSA is forced into exclusive mode.

Do you happen to know of a different way to listen to roon on linux in non-exclusive mode? I’d like to play music in the background while working.

Please review the Rooon Exclusive Mode FAQ: https://kb.roonlabs.com/Exclusive_Mode

Sorry, but I do not know of a solution. Adding a network bridge may help. But this would mean an additional device.

Alright, thanks for the help. I’m going to see if I can maybe use an alternative piece of software to access my music library while working.