Roon Bridge + Shairport

(Benjamin Schramm) #1

Hi All,

Is this possible? I tried to install both, Roon worked just fine but I tried to install shairport after I get the following error:

Unable to Install Shairport Sync: airplay audio player with │
│ multiroom sync │
│ │
http://ftp.us.debian.org/debian/pool/main/o/openssl/libssl1.0.0_1. │
│ 0.1t-1+deb8u6_armhf.deb is offline and/or unreachable.

Thanks!

Ben

(Dan Knight) #2

Hi Ben,

Fixed in our next update (1-2 weeks).

Workaround/solution is available below:

(Benjamin Schramm) #3

Thanks Dan. I’ll sit tight.

Does dietpi update automatically or do I need to do it?

(Tony) #4

Does this affect new installs only? I have Roon & Shairport working on all my Diet-Pi, but they were installed a month or two ago. Does updating to the latest version break existing installs?

(Dan Knight) #5

This effects new installations only, due to Debian repo changing the available packages/URL’s.

DietPi updates must be completed manually when they become available (dietpi-update). All updates are optional, however, we can only provide support the latest version (currently v159).

We have a major release coming soon (v6.0), which replaces v159 and contains vast number of fixes. I suggest avoid updating if your system is working as intended, until that time.

(Tony) #6

OK Dan thanks, will leave them be for now (on a mix of 158 & 159 I think). :slight_smile:

#7

Is v6.0 the next release?

(Dan Knight) #8

Yep:

(Tony) #9

Any ETA on V6 yet Dan? Shouldn’t ask I know but I have just had to do a v159 fresh install and even with your fix, Shairport isn’t visible by any Apple devices (diet-pi says it is running though). Lots of error messages after the fix.

(Dan Knight) #10

V6.0 release Sunday 28th:

2 Likes
(Tony) #11

Thanks. If I get time on Sunday I will give it a go and report back.

(Lanny Hoff) #12

I am looking forward to this fixing my Shairport Sync issues. Would you post a link to the image here when it goes live? The version on dietpi.com is still 157. Thank you for the work you are doing @Dan_Knight. I it much appreciated!

(Dan Knight) #13

@Lanny_Hoff

Hi,

All DietPi images have been updated to DietPi v6.0:
http://dietpi.com/download

1 Like
(Benjamin Schramm) #14

Install went smooth. Shairport worked the first day, now I can’t connect. Roon works without any issues.

(Roland Ashdown) #15

Hi. If I could ask for some help from those with bigger brains than I, I’d be most grateful.

I have a DietPi R/Pi connecting via USB into the back of my Audio-DG NOS-11.

All Roon-Bridge stuff works a treat and really enjoying it (apart from the lack of Qobuz, but that’s a different gripe!)

However, I cannot for the life of me, get Shareplay working at all. I can see it in my iTunes window as an Airplay outlet, and I can see it in the Roon “Audio” setup. But I can not get any audio to playback.

Is there a DietPi-level config I need to do? If so, what? Am I missing something else?

Thanks in advance for any help.

Roland.

(running DietPI v6.7)

#16

Hi there

I setup my RPi 3 Model B+ with the DietPi Allo Web distribution and proceed with a full update using the internal function (bump to version is 6.19.5). The RPi is connected using WiFi, no LAN. It is connected to my DeqX HDP4 using its USB expansion card (RPi USB output).

ROON is working fine, so is GMRENDER using the MConnect HD application with QOBUZ (poor and limited interface, I am waiting for ROON integration).

But SHAIRPORT is not working. The service is up and running on the RPi, but as soon as I start an audio stream from the same iPad (YouTube, QOBUZ …), the service crashes after 1 or 2 seconds and no sound is coming out of the amps. I have to restart the SHAIRPORT service from the Allo Web interface.

My iPad is on IOS 12.1.

Thanks in advance for your help.

Philippe

#17

Just to inform that this issue was closed thanks to Dan, in the DietPi + Allo Web GUI thread.

Thanks again Dan.