Roon cannot connect to HQ Player

I have enabled the globe icon in HQ Player (it’s turned grey). I have disabled all other output devices in Roon. I am still unable to get Roon to connect to HQ Player.

MacMini (Roon server) - Macbook Pro (Roon controller) - Chord MScaler - Denafrips Terminator

Are Roon and HQPlayer running on the same machine or a different one? If they are on the same one, it is easy because you use “localhost” or “” as HQPlayer address.

If they are on different machines, you’ll need to assign static IPs or DHCP will eventually mess up the setup because Roon doesn’t support auto-discovery of HQPlayer and you will need to manually rectify IP address changes.

I have now installed HQ Player, Roon and Roon Core on the same machine. It appears to work, but the volume level is set at -60dB. I can just about hear audio at 0 dB. How do I fix this?

Roon controls HQPlayer’s volume, so you can just adjust it from Roon. Or from HQPlayer. Just do not turn it higher than -3 dBFS.

Default startup volume after installation is -60 dBFS for safety reasons.

Okay, but it’s playing out of my MacMini’s speakers. How do I set default output of HQ Player to my Upsampler/DAC?

From HQPlayer settings…

Sorry to go on like this, but when I select NetworkAudioAdapter in Backend, the Device dropdown below remains empty. I’ve attached a screenshot here for reference.

Do you have a Network Audio Adapter somewhere in your network?

This is my audio chain: MacMini running Roon -> SoTM SMS 200 Roon Endpoint -> Chord MScaler -> Denafrips Terminator DAC. Roon and HQ Player and installed on the MacMini.

Do you have HQPlayer NAA functionality enabled in SMS 200? If it is, it should appear on HQPlayer side, as long as your Mac Mini doesn’t have more than one network interface active at a time.