Roon can't detect my Trinnov which is on the LAN

I’ve rebooted the iMac, the Trinnov, the Comcast router and reloaded the Roon software. Roon knows that the iMac is the core but it can’t find the Trinnov which is connected via Ethernet. I’d like to output the music via ethernet to the Trinnov. the kicker is that it used to work. I haven’t listened to Roon for a while and now it’s crickets. I’ve tried searching these threads but nothing really applies.
Thanks in advance.


Fellow user. On some devices, you need to enable Roon, have you check the settings to see if it might have gotten turn off. Also, you might verify that the Roon Core and the Trinnov are on the same network sub-net via their IP numbers, first 3 groups should be identical. i.,e.

As you suggested, the issue was the network. Amazingly, I was able to figure it out.



I am attempting to use Roon via my Trinnov Altitude 16 for the first time. I have not subscribed yet but have downloaded Roon Remote on my iPhone and also the relevant software on my PC, but in both cases the app cannot detect the Roon Core on the Trinnov. All my devices are on the same subnet and the firewall is on for external WAN traffic only. The Trinnov is on and set to ‘Roon Ready’ as the source but nothing I have tried works. Trinnov is running latest version of firmware. Any ideas ?

Are you sure it runs a core. Roon ready only means it can be an endpoint, not a core.

Bingo ! Thanks for the clarification; I have misunderstood how Roon works. The Trinnov is indeed only an end point and not a core. So I will have to do some further reading around this to understand Roon properly. I take it that I need to install a Roon Core on a PC attached to the same network in the first instance. I will read the relevant knowledge base articles which will hopefully point me in the right direction. Thanks again.

I’m having connection issues also. My Trinnov and ROCK are on different sub-nets 192.167.1.x and respectively.

I’ve tried manually changing my Trinnov to without success and wind up going back to DHCP which puts it back to 192.167.1.x I am unable to access the Trinnov with the 192.168 IP address with VNC Viewer and the ROCK will not recognize it as being in network.

I’m not sure what I’m doing wrong.

I fixed the issue. I have my ROCK NUC wired directly to my Firewalla Gold firewall/router while my Trinnov was wired to my Netgear Wireless router which was then connected to the Firewalla. As it turns out, they assign different IP sub-net addresses, 192.168.67 and 192.167.1.

By directly connecting the Trinnov to the Firewalla, my network assigned a 192.168.67 address which the Roon sees.