Roon can't find its own Core

I have only ever had one machine – a Mac Mini – as my Roon Core.

For reasons I don’t understand, whenever Roon stores an upgrade, I have to remote into the Mac Mini to manually start Roon. Today when I started it, it asked me to login…it’s never asked me to do that.

Now all of my devices are reporting that I’m only authorized to run one Roon Core. Returning to the Mac Mini, it just freezes on “Looking for your Roon Core.” I’m reluctant to choose “Use this Mac” because of what it might do to my library. Restarting the app doesn’t help.

I have gotten pretty disappointed with Roon software quality. That I have to manually restart the app every time (which for me is tedious because I run it headless) has annoyed me for a while. Now I can’t even get it to run.

What can I do?

(just a user here) I have a hunch that your Mac Mini is running the standard Roon app that can operate as a Roon Core as well, rather than RoonServer which is what you should be using for a headless Roon Core. That might explain some of the behavior you have described.

That error suggest that Roon is detecting a second core somewhere. As you are no dioubt aware you can only run one Core per license but you cab have any number of Core/Library set ups and switch between them.

You haven’t got a laptop with a core on it maybe.

I would try @Fernando_Pereira suggestion and use the Server option rather than the GUI version and see if that helps.

The other option is that there is some networking glitch between the Core and your Router , maybe try restating all you kit from scratch starting at the modem/router. Wait until the router has fully connected before restarting the Core PC

I did not know that Roon had “split” between a server app and the client app I used to create my core on the mac mini.

Now that I’m running the server, when I try connect from the client I see this

After I pick to connect to the Mac Mini it prompts me to login.

And then I’m right back to the “1 Roon Core at a time” message…

I have only ever had one Roon Core. I’ve only ever used this machine as the Roon Server. I’m on the machine that’s running Core, so I’m not even sure what role my network would play: it’s “localhost”

Trying to access the server from a different computer on the network Roon hangs here:

If I choose “Choose another Core” it takes me to the same login screen I get when I remote into the server and Roon complains about only having a license for one Core.

Thanks for any help.


Unauthorize your Mac like Roon is requesting that you do. You can then re-authorize it.

This is still suggesting that you have a second core connected , you haven’t got another PC somewhere with Roon Installed have you.

Click Unauthorize as Roon seems to recognize the Mac Mini its showing you then restart Roon and connect . See if the Error repeats

After a long trip I tried to use Roon again. I was stuck with it reporting that my server was running “Production1x” and my client (locally on the server and on my main laptop) was running Stable. Attempting to look for upgrades failed so I couldn’t run Roon at all.

So I installed client and server from the MacMini that acts as my Roon server.

Now when I try to install Roon server it tells me it can’t run because it requires the newer version of MacOS (10.15) than my Mac Mini (late 2012) will run (10.12.6).

Are there any options?


To run V2.0 under your current macOS? No options.

You could run V1.8 Legacy, but to do so you need Legacy on any other machines you access Roon on, i.e. Remotes, etc.

Following the suggestion in the thread and the instructions here

I installed Roon Legacy 1.8 on my MacMini

MacOS All-in-one / MacOS Remote

MacOS RoonServer

And on my laptop/remote controller I installed

And this is the error message I got.

Any suggestion?