Roon control GUI working on Linux using Wine

(Harry ten Berge) #21

You’re aware with my little ‘side project’?

Feel free to contribute :slight_smile:

1 Like
(Kyle) #22

Thank you so much for these instructions! I just followed them on 18.04 with Roon 1.6 and it’s working perfectly!

1 Like
(Kyle) #23

I installed the Roon update that released yesterday/this morning and Roon relaunched with no problems afterwards. I confirmed that it did in fact update Roon running on Wine to the latest version and all was good. I had some Ubuntu updates to install and did so, just completing the install with a required reboot.

Now that I’ve rebooted, Roon will not launch. There are no errors thrown or anything, I click the icon and it looks like it’s about to open but the splash screen never displays and Roon never actually launches.

Anyone do any version updates like this with success? If so, any ideas what might be wrong here? Or do I need to remove this and reinstall it with the latest version using the method above?

EDIT: actually, when I attempt to launch using the icon on my desktop, I got an error:
There was an error launching the application
Details: Failed to change to directory “/home/username/.wine/my_roon_instance/dosdevices/c:/users/username/Local Settings/Application Data/Roon/Application/100600401” (No such file or directory)

And sure enough, when I navigate to /home/username/.wine/my_roon_instance/dosdevices/c:/users/username/Local Settings/Application Data/, the only thing inside is a Microsoft directory.

This is frustrating.

EDIT 2:
I downloaded the latest installer and ran WINEPREFIX=$HOME/.wine/my_roon_instance wine RoonInstaller.exe on it. It installed in less than a minute and it’s running again.

#24

Hello @Kyle_Kerley,

I can remember that the shortcut on the desktop was changed during an update.
You should change your
~/.local/share/applications/wine/Programs/Roon.desktop
to something like this:

[Desktop Entry]
Name=Roon
Exec=env WINEPREFIX="/home/username/my_roon_instance" wine C:\\\\windows\\\\command\\\\start.exe /Unix /home/flori/my_roon_instance/dosdevices/c:/users/username/Start\\ Menu/Programs/Roon.lnk
Type=Application
StartupNotify=true
Path=/home/username/my_roon_instance/dosdevices/c:/users/username/Local Settings/Application Data/Roon/Application/100600401
Icon=93CE_Roon.0
StartupWMClass=roon.exe

And/or take a look at this page and change the desktop-entry-file according to your needs. Then it should work, hopefully.

1 Like
(Kyle) #25

Thanks.

And to be clear: making your change will fix the issue with being unable to find/load when installing future updates?

#26

I had no issues with the latest roon-update today.

(Shalom Ben Zvi Kazaz) #27

A note on updating, when a new version comes out the update doesn’t work from the inside the program as it doesn on windows, i need to install the new version again.
remove roon with winecfg then download and install the new version again with WINEPREFIX=$HOME/.wine/my_roon_instance wine RoonInstaller.exe