Roon Control Volume

Hi Harry @spockfish I am using one Ropieee install purely as a remote with touchscreen, however it can’t control the volume for the endpoint. Is this normal behaviour?

For me, when RoPieee first boots up, the screen shows the album art and play pause etc but no volume indication or slider. I have to touch on the album art to cycle to the second display screen with the black background. I then touch again and get the first screen with the blurred magnified album art background and the volume info and slider show up.

I have to do this little game once after each boot and then it’s fine. Since I only reboot when a new beta comes out (patiently waiting for the hifiberry DAC+ to have airplay hardware volume control), it’s not a big deal for me.

Try that and see if that gives you joy.


I already had. It just fixed at 0db and can’t be moved. I have a feeling it’s because it’s actually fixed volume as the DAC itself can’t be controlled by Roon unless you use DSP volume. However I am using an extension called Deep Harmony which allows Roons volume to control the Harmony Hub which in turn can control the volume of the RME by IR. It works perfectly from Roon app but not from Ropieee touch screen. Or it’s because in this case Ropieee is not playing to the DAC only acting as a remote.

This seems like an older post, nevertheless I have a similar question.

I run Ropieee on a Pi4, connected via USB to my Hegel amp. I wanted to use the Pi for volume control, and set the Hegel to fixed volume. However, I can’t change the settings of the Ropieee Pi in Roon. Fixed volume, DSP and Device volume: none of them allow me to controle the volume on the Pi.

I seem to remember that I could do this before but maybe this was because I then had a Hifiberry Dac added to the setup?

Yes without a hat then your stuck to fixed. The Hegel should show as the DAC which you should be to set to DSP volume on though.

Nope, the Hegel does not show up as such.

Can you show a screen grab of your audio settings?

You should have Ropieee show like my Dining room zone below. Which is my RME DAC connected to it. I can set this to use DSP volume if I want. Should be same for the Hegel

If you have a H390 you can control the volume on it as the USB chip supports this.
You can turn it on in the H390s menu.
The lower models do not support this due to USB chip limitations.

Hello Simon

this is what I have in the audio settings:

Volume limits show minimum and maximum of 0. This is the same for DSP and Device volume

Don’t worry about volume limits that’s normal unless you set it. When you look at the volume level in Roon it should be initially set to 0db which is equivalent to fixed. You will be able to reduce volume from that but not increase you can’t increase whats not there. You need to adjust the level of your amp to a higher level and then reduce using DSP volume in Roon to your correct listening level. That’s how DSP volume works.