Roon + Control4 Issues

@Zach_Lind We are experiencing the same issues, plus some others. We aren’t yet Roon dealers, but I would love to be able to offer Roon as a solution for customers who are music enthusiasts. I contacted Nathan Schwartz with Roon via email, and he asked me to post my notes on the community page. I hope @noris is okay with me posting our notes here. I can start a new thread if needed.:

  1. As far as we can tell, Roon integrates with Control4 via Airplay. This is not cool because it effectively downgrades the quality of the stream from Roon to 44.1 kHz 16bit. The main reason I would consider Roon for our integration projects would be to provide the best experience to music lovers – people who are the most likely of all consumers to appreciate high resolution music.

a. Airplay integration with Control4 is fine overall, but not nearly as good as if Control4 was a true endpoint. This is likely a Control4 matter, rather than a Roon matter, but it still prevents Roon from being a feasible solution for my projects.

Noris asked me to confirm the driver we’re using, and I spoke with our programmer about this. He said that he followed the instructions provided here: Is it possible our problems are occurring because we’re on Control4 OS3?

  1. The Roon integration is buggy:

a. “Search” within the “Library” tab doesn’t work. When you type in an item to search for and hit “return” on an iPhone, nothing happens. The “enter text screen” just goes away. No search is actually performed.
i. This happens in Qobuz and Tidal, as well. It seems to happen anywhere I try it.

I haven’t yet had a chance to test this on a native Control4 touch panel. I will do so to make sure it’s not just an iOS issue.

b. When I do get something playing by selecting a playlist, the music starts playing from within the playlist screen (screen shot attached). There is no way to control the volume from this screen. In order to adjust the volume, you have to press the back button 3 times to get to the C4 home screen, then you have to pull up the screen that shows what is currently playing. That’s okay, except that if you want to go back into Roon to select a different song or something, as soon as you press the Roon button the music stops. Control4 treats this as an entirely new session or something.

  1. I was having a problem with starting Roon from within Control4 then switching to the native app for control once something was playing. This seems to work most of the time, but something causes this to not work part of the time. I’m not quite sure what the issue is. I’ll keep playing with it.

I really want Roon to work for us, but it just doesn’t make sense for if we can’t integrate it with any control systems in a good way. I’m having a hard enough time convincing my engineering team and the company’s owner that Roon is valuable even though there is no DAC or digital output (other than HDMI) built into the Nucleus. These problems will only make it a harder sell.

Hi @Andrew_Cochran,

Thanks for reaching out! I have split your post into it’s own thread so we can better discuss these issues.

What exactly are you trying to output to? Is this for an Airplay DAC/Reciever? Or the Control4 processor itself? This isn’t really clear, so please help us understand this aspect. Also, please let us know the model of the Control4 processor you’re using.

I just tried to reproduce this issue on the Control4 T3 Touchpanel we have in-house and I am unable to do so, search is working properly on the panel. It is possible that this is an iOS/C4 Mobile specific issue. We currently don’t perform any testing on the mobile end since we do not have access to 4Sight, but I have requested that the technical team look into the possibility of adding mobile testing as part of module. I can’t make any guarantees here, but we’ll see what is possible. I would also check to see if this behavior impacts your Control4 touchpanels as well.

It doesn’t look like the screenshot came through as expected. Can you please use these instructions to re-upload it? How do you generally control the volume for other C4 modules, do they have an integrated volume control in the app itself? This sounds like it would be a feature request, but I can take a look to see what’s possible.

Are you pressing the “Roon button” as in opening the Roon app on your iOS device and this causes the music to stop? Or which Roon button are you referring to? If you could share a screenshot of this aspect, that would be helpful.

Can you please provide some more info regarding this issue? What exactly is causing it not to work part of the time. What symptoms are you seeing, the ones you mentioned above with music stopping?


Thanks for the responses. I won’t be back in the office until Friday, most likely, but I will try to answer your questions on that day. In the meantime, I will forward your questions to our programmer to see if he can help us out.


1 Like

@noris I can answer a few of these questions before I get back to the office on Friday.

First, our system is set up as follows:
The Roon Nucleus is connected to our network at the equipment rack, and we are attempting to play music via the Roon integration to our Control4 EA3 in one area: the 2-Channel System in our theater. The EA3 is connected via the 3.5mm analog output to a Bryston analog preamp.

I will experiment further on a Control4 touchpanel when I’m back in the office. I’ll also see if the problem we had with the iOS C4 app is persisting since I last tested it.

When I tried to search, this is what I got: The search bar comes up, I enter an artist name or whatever, then hit search. The search bar disappears, and nothing happens. I’ll test this again next time I am in the office.

This is what you get when you start playing a song from a playlist or track list, and from this screen there is no way to control the volume. You have to back all the way out to the main page of the Control4 app to control the volume.

This is the screen I was referring to when I said that pressing the Roon button at the bottom-right seems to initiate a whole new session, and causes whatever music is playing to stop. Of course, nothing was playing when I took this screenshot.

I will try to get to the office on Friday to experiment further with this. For now, I hope this at least gives you a little more context around what I’m referring to. I assume we’re just making some mistakes in how we configured the system, but our programmer said he followed the instructions in the knowledge base around Control4 integration.

Hello @Andrew_Cochran,

Thank you for the additional information and screenshots!

For the issues on the Control4 iOS app, I would kindly ask that you test for the behavior on a native C4 touchpanel. I am unable to reproduce the search issue and the new playback session issue on a native C4 panel, so I suspect that just the mobile version is affected by these issues.

As I mentioned earlier, I’ll try to see if we can get access to mobile platform testing, but at the present time we don’t perform any testing on the Control4 mobile version, so currently it is a bit difficult for us to file tickets and make improvements for issues that occur on non-native Control4 touchpanels.

This is a feature request. I have filed a ticket with the dev team regarding your feature request of adding volume control and navigation in the same tab, but unfortunately I cannot comment on a timeline of when/if this change would be integrated into our Control4 module.

It sounds like you are using the Airplay output on the EA3 system to route the audio to your Bryston amp. At the current time, routing the Nucleus audio output directly through to the Control4 processor output is not possible.

I would suggest you continue to use the Airplay functionality for convenience, or if you wish to achieve higher sample/bit rates, you can add a USB -> SPDIF bridge to the Nucleus and connect the SPDIF bridge to the E3’s SPDIF input.

If you go down this route, I would make sure that the SPDIF bridge you use is compatible with Linux, as the Nucleus has a Linux-based operating system.

No rush, if you get a chance to test for this behavior on the native Control4 touchpanels when you’re in the office, do let me know how it goes!