Roon converting 16/44 PCM to 16/24 then volume levelling by -2db?

Logitech Transporter fed music via Ethernet from Roonserver PC.

This is new behaviour, only noticed it since my last reinstall?
Does this consisently, wether AIFF, FLAC or MP3 pcm.

Whats the story guys, this is a new issue.

Thanks.

hi, not really a ‘problem’. lot better to convert it to 24bit and then apply digiital volume reduction by 2dB - with 24-bit you are sure not to ‘lose’ any quality whereas with 16bit there might be some (not sure who could hear it though ).
so - i think this is working as designed. could be even 32bits and it would still be fine®.
yes you probably to get bit more streamed to your transporter via network but again that is irellevant.
hope this helps

1 Like

I think there is some confusion. It is likely converting bit depth from 16 bits to 24 bits, which affects the dynamic range. This does not harm the signal, it simply adds more options for the volume processing. The sample rate, 44.1kHz, is hopefully unaffected. If the sample rate was cut in half, you would know, because that would also cut the frequency response in half (treble would disappear). The -2dB is probably from the analysis done to the files to calculate playback volume, or to avoid known clipping on your device.

Even with LMS and a transporter (or any squeezebox), LMS streams 16/44.1 as 24/44.1. As noted this allows les destructive digital volume control.

Gary is right. Going from 16 bits to 24 bits means going from 96dB to 144dB of dynamic range. Meaning you could take the entire 96dB range of a 16-bit track and turn it down 48dB before you start throwing away any information. Obviously this example ignores the noise floor of your equipment, but the point is adjusting the volume down a few dB won’t negatively affect anything and gives you the flexibility and precision of digital volume control.

Thanks Guys.

Just odd though that it started doing it all of a sudden?

Also,
When looking at audiopath it is no longer showing as purple, bit “just ok”.

To be honest, I’ve always prefered a direct signal as possible, played around with upsampling and always came back to native bitrate/sampledepth.

Dont use digital volume at all, so this feels in the way.

Any way to stop it and get back to what it was?! :slight_smile:

Do you have “use volume normalization” (or whatever roon calls using ReplayGain/Volume normalization) turned on in Roon settings? If so, because of this it will not show as “purple”

Thanks Gary,
Where would I find that setting?

Under audio/Transporter all I have is Volume control on/off and DSD/PCM filters?

Hi Gaz,

Volume Leveling and Crossfade are found by clicking the Zone Picker on the bottom right of the screen, next to the volume icon. Then click the gears icon next to your Zone.

Cheers, Greg

Cherrs Greg,
Switched off volume kevelling and Im back to direct streaming. that did the trick!

Thanks guys for your help.