Roon Core Preventing Mac from Sleeping

Core Machine (Operating system/System info/Roon build number)

Mac Mini 2012 running macOS 10.14.6 (18G6032) and Roon 1.7 (Build 610)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue

Dear Roon Support:

A Mac Mini that is running Roon Core will not sleep if the Roon software is running, even if there are no active connections to the Roon Core software on the Mac Mini. The audio analysis process ended days ago, and no other activity is occurring, that I am aware of, within the Roon Core on the Mac Mini.

Thank you for your assistance.

Should I install Roon Server instead?

Hello @RoonUser657932327, and welcome to the community! RoonServer does sound like a promising option for your use case and here’s our article on migrating your content.

Dear Nuwriy:

The Mac Mini continues to have a problem with insomnia if Roon Server is running. If I quit Roon Server, the Mac Mini sleeps after a few minutes. I believe I have determined that the insomnia is most likely to occur if a playback session is ended with tracks in Roon’s queue.

Do I need to file a bug report elsewhere?

Hello @RoonUser657932327, my apologies for the delayed response. I’d like to get a report over to our team for further review, could you please reproduce the issue one more time and reply here with a timestamp when you do? I’ll enable diagnostics for your account and create a report for our team.

Dear Nuwriy:

Thank you for your response. My Roon account is not tied to this account because I do not want to have my Roon account tied to a public forum account. Is there a way to submit the logs to the support team privately or within the Roon application?

Thank you again for your help.

Hello @RoonUser657932327, this link allows uploads only, so only my team will be able to review the data. Does that work for you? That or you can PM them to me! Either way, make sure to include a timestamp.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.