Roon Core stops playing when songs change bit rate

Hi there,
My Roon Core stops playing every time the songs in the playlist change bit rate from 44.1/16 to 48/16 KHz.
It happens as well once the song change is from ALAC to m4a.
Songs in a playlist with the same bit rate play flewless, regardless of the file type ma4 or aif.

In Roon remote and on the Core iMac the next song is displayed but will only play once I hit the play button,
or use the Mu-so remote.

Tried as well different CD import tools, iTunes, fre:ac, no change.

Just tried another zone with a Sonos Play:1 and it worked flewless 44.1/16 to 48/16 to 44.1/16 songs.

Any ideas?

Thank you,

Roon Core Version 1.3 is running on
iMac Mid 2010, 3.06 GHz, Intel Core i3, 12 GB RAM, macOS 10.12.3
Musik Database stored on an Apple TimeCapsule 3 TB,
No iTunes mediathek integration,
Musik files are either ALAC(m4a), AIF(aif) or MP3, all either 44.1/16 or 48/16,
Musik output on Naim Mu-so, latest Software release installed,
all network connections hardwired 1 GB Cat 6.

Hi @Helmut_Lehr ---- Thank you for the report and the feedback. May kindly ask you to verify which zone you are experiencing this issue with and the hardware being used?

Furthermore, in your zone settings have you tried using the Resync delay feature found under the device setup menu?


Hi Eric, thank you for your fast reply.

It happens in a zone with the Naim Mu-so.

I tried the Resync Delay and are up to 3s now already.
The problem is consistent with following songs:
44.1/24 (from Tidal) to 44.1/16 (from Roon Server). The other way around it works flewless.
ACC files from Roon Server to 44.1/16 from Roon Server.

The problem is solved for the following songs:
44.1/16 to AIFF and vv.

Best Regards

Eric, just recognized the following:
Roon is showning the connection via Airplay even though the Naim Mu-so is connected via ethernet,
and WiFi is disabled in the Mu-so settings.
Could this cause a significant delay in transfering the switch parameters between Roon Server and Mu-so?
Just guessing.

Best Regards

Hi @Helmut_Lehr — Thank you for the follow up and the feedback, both are appreciated! My apologies for any confusion on my end, but I am need of some clarification.

I did some research into the the Naim Mu-so to see what interface options are available for the device and according to the specs listed here the options are: UPnP, AirPlay, Bluetooth, USB, and Optical.

  • Can you verify for me which of these you are using while working with Roon?

Lastly, you mentioned the following:

44.1/24 (from Tidal) to 44.1/16 (from Roon Server).

  • Are these both streaming from within Roon?

The problem is solved for the following songs: 44.1/16 to AIFF and vv.

  • Can you provide some further insight into this statement?


Hi Eric, thank you for getting back.

The Mu-so shows an AirPlay connection and so does Roon.

I did some screanshots and placed them in a public Dropbox folder.
This may clarify your questions a bit more.

Best Regards

Eric: Don’t know what is going on in my system. It looks like Roon is playing only to the AirPlay of the Mu-so and not to the UPnP.
Honestly, I don’t know how to change that.
I’m a bit desperate.

The most anoying thing is when I play radio and the songs are changing bit/sampleing rate forth and back, then it stops almost every song.
I cranked up the Resync Delay already to 5s but still the same issue.
This renders Roon a bit useless to me at the moment even though I like it so much.

Best Regards

While listening to the radio function I recognized that only files which have been copied from the iTunes library onto the network share on the Time Capsule are causing the issue.
Looking into it I figured that something must be wrong with such files.
Once I imported the albums again with fre:ac audio converter in a flac format, they are not causing any issue anymore.

Any idea in this direction?

Best Regards

@support :
I created a playlist containing songs with the different sample/bit rates and file types I have.
It played flewless in a zone with Sonos Play:1 endpoint.
The same playlist played on the zone with the Naim Mu-so as an endpoint connected over AirPlay stopped every time the sample/bit rate or the file type (FLAC, ALAC, AAC) changed.
Only songs with the same sample/bit rate and file type play one after the other.
Any Resync Delay setting between 0s and 5s doesn’t change the behavior on the Mu-so.

I don’t know what to do or try anymore to play seamless music on the Mu-so.

I installed a Twonky server on my iMac and all music files regardless of smaple/bit rate, type or sequence play flawlessly via UPnP now.

My understanding is that there is something wrong the way Roon handles the communication with the Naim Mu-so.

Please assist if you do have any ideas.

Thank you,

I can’t help with your issue unfortunately but I can confirm that the only way to connect to the muso is via airplay, Naim at the moment do not provide a Roon bridge in their devices.

I seem to remember @mike having access to a
Mu-so to test previously so perhaps he can test this for you.


Thank you John.

Hi Mike, do you have any experience how to get songs with different file types and sample/bit rates played on a Naim Mu-so without Roon server stopping at any change of file type and/or sample/bit rate.

As mentioned in my previous posts it play’s flawless on a zone with a Sonos Play:1 endpoint.
Streaming from a Twonky server thru the Naim app works as well.

I do like Roon very much and like to keep it as the primary streamer with Tidal integration.
Appreciate your input on this.

Thank you,

Hi @Helmut_Lehr ----- Thank you for the feedback, when I talk to Mike today I will inquire about your question. We appreciate your patience while we look into this issue for you.

In the meantime, are you noticing the same behavior if you play content from local storage on the iMac that is hosting your Roon core?



Thanks for coming back.
I don’t have any other content on the iMac running the Roon core.


Hi @Helmut_Lehr – sorry for the confusion here, but to be clear Roon does not support UPnP. We can stream to Roon Ready devices, as well as Airplay, Meridian, Squeezebox, HQPlayer, and Sonos. You can read some more about why we don’t support UPnP here.

In this case, the only one of those capabilities the Mu-So has is Airplay, so I would expect any files over 16/44.1 to be downsampled.

Does that help @Helmut_Lehr? – are you still having issues switching sample rates? Can you confirm that these issues persist when the files you’re playing are stored on the same machine running your Core, as opposed to being stored on the Time Capsule?

Hi @mike: Thank you for the link about UPnP and AirPlay. This was interesting and informative for me.
To be honest, I don’t mind how the songs get into the DAC as long as they get their.
I don’t believe that I am a person being able to hear the difference in sound from different transport protocols.
What I get out of Roon to the Mu-so, to me, is a good quality sound and that’s what I wanted.
Anyhow it is always interesting to know about the background of things.

Your hint playing songs directly from the harddrive of the iMac with the Roon Server, did the trick.
I copied the entire library to it, and voila - it’s all working now.
Do you mind giving me an explantion why it doesn’t work with the TC, even though it is connected with GB ethernet?

Thank you and have a nice weekend. You made may day!

1 Like

A post was split to a new topic: A switch in bit causes end point to disappear