Roon Database not populating after migration

Roon Core Machine

Core machine: 2-bay QNAP HS-264 NAS running Roon Server v1.8 (build 952)
Intel® N5105 4-core/4-thread processor, 2.9 GHz
8 GB RAM

Networking Gear & Setup Details

Remote on Amazon Fire HD tablet v1.8 (build 952) wireless

Connected Audio Devices

Wired USB from QNAP NAS to PS Audio DAC

Number of Tracks in Library

20,000 tracks

Description of Issue

Roon was working well for 2 months on single SSD in QNAP NAS (core and library on same SSD)

I then installed a second SSD and reformatted both SSDs to use them as single storage devices rather than RAID. I re-installed Roon Server as a QNAP package on one SSD and on initialisation I got a message to deactivate the previous core, which I accepted. The core showed up and I logged in before realising I should have actioned the backup restore first.

Since then I have been unable to either successfully restore the database backup or indeed populate the new installation database.

If I uninstall the server and manually delete the RoonOnNAS folders recursively I can then re-install the server but when I restore the backup it seems to restore to 100% and then finds but doesn’t connect to the core.

If I try a fresh install and re-login I can open the core and add my music folders, but Roon does not populate its database and no albums show up.

I have tried complete re-boots (including network) several times over the last 2 days to no avail.

I’m out of ideas…

If no music files are populated, please check if the storage paths are still correct.
If this is the case, please try to create a new shared folder (you can name it “test” for example, but it does not matter).
Please remove it again directly after it has been created (yes, I know this sounds weird…)

Please check, if a “Force Rescan” in Roon’s storage settings will find your music files now.

Thank you for getting back on this, your time is appreciated.

I didn’t try your solution because yesterday I finally managed to get the music files populating again.
Unfortunately I suspect I may be experiencing the QNAP issue disscussed in:

I tried most of the workarounds there to no effect. What seemed to work eventually (after about the 8th time of trying) was to stop Roon in QNAP and uninstall it. Then ssh into QNAP and delete the RoonOnNAS folder recursively. Then reboot the NAS and also the network router, and re-install Roon on QNAP. (I also set Guest Access Rights to Read only for my RoonServer shared folders but don’t know whether that’s necessary).

Anyway Chris, Roon is functioning normally now and has survived a QNAP reboot following the firmware update to 5.0.0.2055